Is it possible to get rid of jagged lines (i.e. to anti-alias) in real time?


#1

Hello

It is possible to get Sketchup (latest version) to anti-alias to screen in real time. The lines in Sketchup are all extremely jagged…

Fwiw, I am using Windows 8.1 (Pro x64) running Graphics card: ATI Radeon HD 5770.

I am still very much trialing Sketchup and do not want to spend any money getting rid of the jaggedness of lines.

[I am used to using Xara Designer Pro which has been anti-aliasing very fast in real time for over a decade]

Fwiw, I am using AMD Catalyst Software Suite (v15.20) and AMD Catalyst Control Center (v2015.0804). I also have something called AMD Gaming Evolved (powered by Raptr) but I have no idea if gaming is relevant to Sketchup (although both are 3D…) ??

Apologies for the newbie question…

J


Jagged lines in SU models - straight lines as well
#2

Go Window/Preferences/ Opengl and you can choose the best option that your graphic card supports.


#3

and it those settings can be dependent on graphic card settings.

I can apply better anti-alias settings in graphic card settings. As mine is Nvidia card, I am unable to say anything about ATI Radeon cards.


#4

Thanks. This is what it says… :^/

I


#5

So, all the settings are correct in SketchUp.
The better lines can be be shown once graphic card settings are changed

we get something like this as Nvidia users.


#6

Well, try clicking a different setting in the box and restart SU to see what works for your setup.


#7

josephkim626 - Sorry I cant really read your screenshot.

The only place I can find talking about 3D is under Gaming

If I choose something other than “Choose application settings” other options appears such as:

  • Anti-aliasing samples (options: none; x2; x4; x8)
  • Filter (options: Standard; Edge detect)
  • Antialiasing Methon (options: Multi-sampling; Adaptive multi-sampline; Supersampling)
  • Morphological filters (options:Off; On (full screen Direct3D application only)

I’m beyond the limits of my knowledge on all this!


#8

Well, try clicking a different setting in the box and restart SU to see what works for your setup.

Which box(es) do you mean?..


#9

Did you try changing to a higher AA setting? At least three options show in the window you shared.


#10

In the box where it gives you different options to choose. 2x 4x etc


#11

Try @Box’s recommandation first.


#12

OK, I’ve worked out how to add the Sketchup application in the columnn under Application Settings.

With Sketchup selected as the application it turns out that “Anti Aliasing samples” now offers the only options of “None; 12x; 24x”, however if I select anything other than none then AMD Catalyst Control Centre crashes out closing itself.

I shall try some more options on the other fields. I may need to reboot more shortly


#13

So you aren’t going to try what Box suggested?


#14

Ah… I had now idea that leaving something highlighted was a possible method of selection! [who wrote this stuff?(!)]

RIGHT now we’re talking!

Yes anti-aliasing is working. Not as good as Xara but at least it’s working. Many thanks folks :smile:


#15

Yeah, highlighting the field for specific setting is a bit odd method.
It looks rather like some sort of values that are already set by system settings.

I’ve recently found that out as well.


#16

Fwiw, this may not be obvious in a screen shot, but in use the anti-aliasing in Sketchup is nothing like as good as Xara’s!

And none of those other settings I found in AMD Catalyst Control Center seem to make any difference!


#17

So clicking an option in a predefined box/window to highlight, it then clicking Ok is somehow strange!


#18

So clicking an option in a predefined box/window to highlight, it then clicking Ok is somehow strange!

Absolutely. I know of no other application that works by mere highlighting. The usual convention is a tickbox (or radio button or dropdownlist).


#19

I don’t really care, but Windows explorer for example.


#20

I would have to agree with you on this.

BTW, I have only up to 4x setting in SketchUp. But use Nvidia application mode as “enhance the application setting” to use 16x. which gives me a bit more smooth line. (similar to your Xara)