Is Geometry Reaching Math-Limits?

#1

Enclosed DC seems to work Ok to our needs. Change the Angle variable and all holds fine.

BUT; when model is saved, I loose some geometry. Is the model exceeding SKP’s Math-Limits and small geometry is discarded on save?

NOTE: Red Axis appears exceedingly Long. See attached Pic. Wonder if this is some kind of a clue on this challenge.

Nino!

Wedge Save Temp.skp (30.5 KB)

0 Likes

#2

Seems I fixed it by moving the Origin to Zero along the Green Axis. Origin used to be at the Highest Point on the Model which placed it a fraction of an inch along the Green Axis. Don’t understand why it did not work before. Would still appreciate a reply.

Wedge Save Temp 01.skp (40.4 KB)

Nino

0 Likes

#3

Are you saving the file for later use as component? It could be that there are some edges and faces hidden while making the scene in your model. Depending on the settings, scenes remember hidden geometry.

The best way to save components is to have a ‘working file’ were you create and edit components, and then use the contextmenu (right-click on selected component) and choose : ‘Save as Component’

In general, if you create components for later use, you can compare it with the workflow of uploading files (A component could be seen as a little model-file) to the 3D Warehouse:

https://help.sketchup.com/en/3d-warehouse/making-great-3d-warehouse-model

1 Like

#4

Yes Mike: tested using Unhidden Lines. Also Saved-As Compo and re-imported to New File. As reported, moving Origin to outermost face seems to have taken care of errors and disappearing geometry when saving.

Thanks for suggestions.
Nino

0 Likes