Intersection Discrepancy. Why is this happening?


#1

I don’t know if it’s the acute angles I’m working with but I keep finding gaps. I have gotten it to the point that I can only see the gaps in Parallel Projection, but I have no idea how to make this go away. I understand that this is the type of issue that can only be confirmed, and not easily diagnosed without watching me construct the model so I’m hoping this has happened to someone else. The discrepancy is so small that the tape measure tool won’t even give a reading, but there are gaps and I don’t know why. Why would Sketchup reference extremely close to the nearest endpoint, rather than on the nearest endpoint? If you zoom anywhere multiple planes intersect in Parallel Projection mode, you will see small gaps.


#3

ModelGrid.skp (230.5 KB)

With Scene of issue


#4

You have a camera clipping plane. In your case, pay attention to part covering a change in the Field of view.


#5

I’d totally forgotten about changing the field of view, thank you. However, I don’t understand how that would affect Sketchup’s referencing to endpoints.


#6

http://cl.ly/image/3U303w1Y3m1Z

Image of problem


#7

The cutting plane affect how close one can move into the model to see.

Switch to Camera > Perspective and model with that setting. I forget what parallel projection is good for, but modeling isn’t one of those things.

I took one of your BaseUnit and BaseUnitTop, exploded everything, erased the inner geometry and closed in the open bottom of the BaseUnit. Selected all , r-clicked and Intersected with model for good measure. Made that assembly a Group and the group was detected as a solid. The corners meet. The model is fine.

A great many bits inside the BaseUnits are Components. And those funky-looking intersections under parallel projection seemed to be where intersecting components. When all those components were exploded, I didn’t see the funky stuff under parallel projection.


#8

Interesting. Thank you for your help. To be clear I didn’t do the modeling in parallel projection, but because of the clipping plane I could only zoom close enough to see the errors in parallel projection.

Thanks again, I really appreciate your help!


#9

I agree, it was interesting. Though the word error is a bit strong as nothing was wrong with the geometry placement. Rather the camera in parallel projection was playing tricks given the tight zoom with all those intersecting components.

Parallel projection is used for printing to scale using standard views.

Would it be OK if I add some animated GIFs of your special effects to the SketchUp Sage? It’s an interesting annoyance.


#10

I suspect there are some problems being caused by incorrect layers. It seems you have some raw geometry on different layers.


#11

Sure, it’s ok with me. Thanks again.