Installed Make 2017 on new PC but it crashes upon launch


#1

Hi Folks,

Installed Make 2017 on a new PC. Upon launch (after choosing template) either nothing happens or i get a bugsplat that says:

“This crash is most likely caused by the presence of a buggy Microsoft DLL file (C:\Windows\System32\mfc140u.dll - version 14.0.24210) on your system.”

I don’t really know what this means but i follow the instructions to download and install “version 14.11.25325 of the Visual C++ 2017 Redistributable.” I’ve done this several times without fixing the problem. Also restarted my system and reinstalled Make several times.

From poking around on the forum here it seems the problem could be with my integrated Intel graphics. I went directly to the Intel website and downloaded the latest driver. Still doesn’t work. Do I need a graphics card?? My system is Intel i7-8700 cpu @ 3.2 GHz with 16 GB RAM. Seem like that should be enough? In any event, I ran the SketchUp Checkup application and it says I’m good to go:

“Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card RAM requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!
Success: Graphics card capability tests have passed.
Congratulations, your computer has met all the minimum requirements to run SketchUp 2018.”

What should I try next? I’m fine with installing a graphics card if i knew that would be my solution. Am i missing something else??

Thanks!!


#2

Did you right click on the downloaded .exe file and choose “run as administrator” to install. If you did not install in that manner, do so and choose repair. Hopefully that will get you up and running.


#3

Thanks for the reply.

I did try that previously, and tried again just now. The install still behaves the same way.


#4

the CheckUp tool checks for the minimim system requirements only but can neither evaluate the maturity of the OpenGL support of the graphics card driver nor the presence resp. correct installation of the SketchUp prerequisties (MS runtime libraries).

The offline installer of the recent MS Visual C++ Redistributable f. Visual Studio 2017 x64 (rev. 14.16.27012.6) can be found here (direct link).

Unistall the currently installed version (as long as not shown anymore in the Windows software control panel), restart Windows and install by “right-click > Run as Admin”.

The recent driver version 25.20.100.6373 (W10 x64) of your intel HD 630 from 11/05/2018 can be found here.

If you could get SU to launch, disabling “Windows > Preferences > OpenGL > Use fast Feedback” might help too.

If nothing helps you could do a ‘fallback’ to the OpenGL-wise less demanding SketchUp Make version 2016 which additionally does allow to disable the hardware acceleration (= OpenGL) from the dialog mentioned above… and also externally if required:


#5

Thanks for this.

I followed your instructions on installing the MS Visual C++ Redistributable, and also the most recent graphics driver. Make '17 still crashed upon launch.

However, I installed Make '16 and it works perfectly (even with OpenGL set to use hardware acceleration, max texture size, and fast feedback). So…this means not having a stand alone graphics card IS the problem I’m having with Make '17??

Something else: when I installed the most recent graphics driver I had the following dialogue box pop up

Dll%20snip

The graphics driver apparently installed fine, but this seems like a good clue. I saw this popup one other time randomly, but dismissed it not knowing what it was. Understanding DLLs is beyond my tech pay grade, but I guess it doesn’t take a genius to conclude that something is buggy with my DLL files. Any advice on troubleshooting that? Seems like this is maybe not so much a SketchUp problem but that my Windows install is not working as it should.

Any further advice is greatly appreciated.


#6

This does appear to be a Windows issue. Your profile indicates your computer has an Intel graphics adapter (integrated graphics adapters are not recommended, by the way.) but this error seems to point to the Nvidia GeForce Experience application. See this. This problem seems to be caused by NVIDIA GeForce Experience. You should be able to fix it by reinstall NVIDIA on your system or by disabling the NVIDIA Geforce Experience Service.). Do you have an Nvidia card, too?


#7

Interesting. I don’t have a NVIDIA card but I did on my old PC and I used PC Mover to automatically transfer all my files and applications to my new PC. It looks like some of the NVIDIA files came along for the ride. I uninstalled them using the DDU application (the NVIDIA driver didn’t show up on Apps & Features list so I couldn’t uninstall it that way). I was hopeful this would allow Make '17 to launch but alas it did not.

I guess my next move is to install a stand alone graphics card.

Thanks for the help.


#8

Interesting indeed.

You might try using a registry cleaner and a cold reboot and see if there’s any change.

If you can install an Nvidia graphics card, that would be a good thing since integrate Intel adapters have proven to be problematic.


#9

this may work somehow but is in general not recommended because issues (your now are affected by) might arise.

If you wanna upgrade your graphics subsystem go for a nVIdia GeForce GTX 1050Ti or 1060 (VRAM depends on screen resolution), the first does have the advantage being available in versions w/o additional power connection required (75W of PCIe slot sufficient), in low-profile design (= half height) and w/o active cooling (= no fans).

For benchmarks see here.