Importing dxf/dwg files--corner points are dropped

#1

bottom front.dxf (46.6 KB)

I’ve been designing flat (2D) objects using CorelDraw, then exporting them as .dxf files for import into Sketchup.

I’m designing in CorelDraw so I can laser cut 3 mm acrylic. The pieces are then assembled as a 3D object–I’m using Sketchup to see the 3d objects that will be built from the 2D pieces. I can spot issues in the design using the 3D model–it’s much better than wasting material!

This has been working well–I got help from DaveR to make it easier to create surfaces from the imported dxf files, but no issues other than that.

But, for some reason, I’m now having a strange issue. When I import the .dxf file (see attached example), the corners of the enclosing shape are not correct.

I have simplified the object down to a rectangle and can import the rectangle without issue. I then add the internal rectangles that are aligned with the top edge, and still there is no issue importing. But, once I delete one side of the internal rectangles that are aligned with the perimeter of the outer rectangle (to get the tabs) the corners of the outer rectangle aren’t correct (not even close).

I know the .dxf file is good, since I can import it back into CorelDraw with no issue.

I’m using maximum precision in CorelDraw. I’ve tried both with length snapping enabled and disabled, but it makes no difference.

I’ve tried dwg and dxf files, both have same issue.

bottom front.dxf (46.6 KB)

I’ve done about a dozen similar Corel->dxf, dxf-Sketchup and haven’t seen this issue. They shapes are all pretty similar, rectangular shapes with jagged (tab) edges and internal rectangular holes. Something must now be different in my Sketchup setup, but I can’t figure out what it is. I don’t recall changing anything relevant.

0 Likes

#2

I’m using maximum precision in CorelDraw. I’ve tried both with length snapping enabled and disabled, but it makes no difference.

Meant to say:

I’m using maximum precision in SketchUp. I’ve tried both with length snapping enabled and disabled, but it makes no difference.

0 Likes

#3

What are the corners supposed to look like? Can you make a screen shot that shows how they look in CorelDraw?

0 Likes

#4

Square corners.

0 Likes

#5

pcbmount.dxf (213.8 KB)

Example of a similar dxf (bit more complicated) that has no issue after importing.

0 Likes

#6

Are the exterior edges divided into short sections in CorelDraw?

I see this when I import it.

Funny thing, when I open it in my CAD program, I don’t see anything.

0 Likes

#7

Not sure on that last example, but I’ve been combining all the curves into a single object. I just tried keeping them separate, but that had no effect.

0 Likes

#8

Strange. When it comes down to it, that would be simple enough to model in SketchUp without using CorelDraw but it still ought to import correctly.

FWIW, when I try to select the perimeter edges, only the ones in blue get selected. Entity Info reports there are 20 edges. I would expect only five edges.

0 Likes

#9

bottom front.dxf (171.6 KB)

I did the export again from Corel,this time making sure it was a “combined” shape. Not sure what the previous upload was, but it doesn’t seem to affect the issue.

0 Likes

#10

I tried enclosing everything with a rectangle. That rectangle imports ok, but still the (now) internal shape is messed up.

0 Likes

#11

When I open in DraftSight and zoom right in to those problem corners, this is what I see. There’s something about the DXF that isn’t quite right.

1 Like

#12

Surfaces are there as expected after exploding and running “make faces”.

I can’t laser cut from Sketchup–needs to be in CorelDraw for that. Sure, I could design in both, but I’m doing a lot of this stuff and trying to get a good workflow in place.

And, CorelDraw is much better for drawing 2D stuff to specified dimensions.

0 Likes

#13

There’s something wrong with the way the CorelDraw file is drawn or exported. When I select just the edges of the rectangle, it shows 27 edges, not the 4 that there should be.

0 Likes

#14

I was really only suggesting drawing it from scratch in SketchUp so you could make the 3D view of it but you could model in SketchUp and make an export from the model to get your file for the laser.

0 Likes

#15

Is that last picture after importing into Sketchup, or your 3D program? If sketchup, we don’t know whether the issue is the file or the import mechanism.

0 Likes

#16

Mine, with the green is in SketchUp. Ian shows the import into DraftSight. The fact that two different programs import the DXF showing the same issue would make me think it’s the DXF file and not SketchUp.

0 Likes

#17

I can’t see anything in Ian’s image. So, it’s not importing at all?

0 Likes

#18

He shows a corner cut off like I’m seeing.

1 Like

#19

That chamfer is the top right corner of the DXF file you provided, it comes into SU the same.

0 Likes

#20

Ah, I see it now. I didn’t realize the object outline was the dotted line. Thought that was axis or guilde.

I agree with your conclusion. But, it strange mostly there are now issues.

I much prefer to do 2D design in CorelDraw. Is there another path into Sketchup that might be more reliable? The image formats don’t seem to work for this.

0 Likes