Importing DWG to sketchup pro 2016


#1

Hello,
when I try to import dwg to my sketchup pro 2016, it is in a very low quality(lines are not straight, circles are not circles), a friend of mine uploadsthe same file to his older version and it is in a really good quality. What should I do to improve the quality of the drawing?


#2

looks like raster data (picture/scan), can you upload the DWG.


#3

Could also be your graphic card. How do simple rectangles look?


#4

You do realise that SU is a 3D modelling platform? If you have a plan on the ground (as above) then rotate the view and tilt it slightly, all the lines will go a bit jaggy (anti-alias will smudge the jaggies a bit) and the circles will ‘squish’ and become slightly oval.

If you want to improve the quality, use Layout to show 2D plans. Or use the program that generated the DWG. (Or use the built-in “top” view)


#5

if your graphic card driver isn’t able to cope with it.
If your system works well with SU then your lines won’t have jaggies.


#6

Have you tried going into Parallel Projection mode and viewing your model from top? Seems to me, you’re slightly off the Top View.


#7

It looks like the image is slightly “skewed” and not on any axis which would account for the jagged lines. Turn off “end points” in the styles menu and you will remove the “dots” at the corners and line intersections.


#8

True, but it could be turned off: Window | Preferences | OpenGL | Capabilities - make sure that the one with “anti-alias” of x4 at least is selected before closing the dialogue (if there is one at x0 selected then you will see jaggies)

Your screen resolution can also have a bearing on just how smooth the lines are.


#9

Hi malgaszalek, hi folks.

You can also turn off endpoints for edges in the Style Window.

Just ideas.

Jean


#10

As everyone have stated, this issue seems like more of hardware. Will you be able to provide details of your setup?

what model of laptop, or graphics card name at least. And monitor/screen resolution.

your friend probably had different and better setup than you are.

if you are stuck with one setting because of budget and etc. Then, do stuff like unchecking Endpoints and Extensions in Styles.
Also, when you export the images as jpg elsewhere, you might get some edge improvement by allowing it to be higher resolution jpg. (lines will be smoother and thinner, though this depends on your graphics settings)


#11

Just a wild guess but are you using the proper import units for the dwg?
Look in File - Import - DWG/DXF - Options


#12

The problem is that the same dwg file uploaded to older SU version looks great. It is just with SU2016 that is has shitty quality. Why?


#13

It is not a problem with units and card.


#14

Also, he imported the file for me to sketch up and now i work on high quality file.


#15

guessing doesn’t help here, why not provide the DWG for providing you with a qualified answer?


#16

Or provide both the DWG and the SKP. To me it looks like the template you have chosen in 2016 uses some fancy “hand drawn” Sketchy Edges style, and just switching to one of the default styles would fix the look.

Anssi


#17

You can change line style to single straight line with styles dialog. (Window - Styles - Edge)
Check only Edges, Check off others.