Imported working file from SKP Free into SKPMake 2017 lost all navigation tools but zoom

I created left and right panels for a couch design. I am a real newbie at this, but I did attach and articulate the panels to ensure they were fitting properly to one another and the horizontal axis. I “hacked” away at this using the rotation tool and guide points and lines. By the time I finished putting all the components back into the same horizontal plane I zoomed out to discover that my entire component group was floating in a skewed plane and I could no longer navigate reliably around the model, with even minor nav. inputs flinging the entire model anywhere in space. I partially overcame the problem by importing the couch assembly into an entirely new file but still not in line with red and green vectors. The problem I created really “blew up” when I imported the same file into newly downloaded SKP 2017 version and lost all Nav. tools but zoom. A bugsplat report came up.
I deleted entirely SKP 2017 and reloaded it but still no nav. tools on any template file, see below. Any help is kindly appreciated.

Sample 1.skp (136.0 KB)

The file you upload only has the scale figure in it. No couch or any other components.

As for the issue you are showing, how are you installing SketchUp 2017 Make? Your profile says your operating system is Monterey which of course won’t be supported by SU2017. It might work but might not.

Did you send in the Bugsplat report with something to identify that it came from you? It might be that @colin will take pity on you and look it up.

2017 isn’t too stable in Monterey, and may well quit for no reason after a while.

Your bugsplat window also seems to have failed.

I included the blank file only as an example of the nav. issue - zoom functions are working but orbit and pan functions are disabled. Up until I imported SKP Web couch file into SKP 2017 it was working well and had no issues quitting or otherwise and except for this nav. issue all other design commands are still active. I have since deleted SKP 2017 off my hard drive and re-installed it but still have the same nav. issue embedded in the new install on all files every time. I did not send a Bugsplat report at the time and just kept a copy of the one I posted here on file. I’m wondering now if I uninstall SKP 2017 again and download a trial SKP pro version instead whether the nav. problem is likely to migrate into it there as well? Ok, I think I’ve just answered my own question and become more confused (if that were possible) at the same time.

I opened my SKP on Web free version just now, to download the couch file here for you to look at, and the same nav. problem has just jumped into all my files here, disabled orbit/pan commands. The next thing to happen was my online account completely crashed. I logged out, logged back in, and none of my folders and files will display or load either now. To trouble shoot the problem, I just created another Sketchup account under a different email address, and opened it and it too is bugged by the same nav. issue. Original account still will not load at ll. How is this possible? considering I am opening web based SKP software and have already uninstalled all SKP software from my hard drive again. I apologise for this long winded rant but I am truly beyond bewildered at this point. Aside of these issues, I really enjoyed using the software while it lasted.

Sounds like your mouse is broken.

I wish it was! Mouse working fine as is my touchpad.

I stand corrected sir! You have indeed hit the nail on the head! I investigated a little further and there was some issue between my track pad and mouse preferences. Problem solved!!! Thanks a million!! And thank you very much to the other guys who took the time to respond as well. Kindest regards, Arty.