Import Failed

i am trying to import a contour file from autocad and its not importing saying impot failed

why am i getting this error please help. I have attached the file.
G2.dxf (962.1 KB)

Be sure to look under the Options Button when importing files.
The settings shown below worked fine.

thanks but still i get the same message

this is when i untick the preserve origin option

The DXF file you shared works fine for me in SU 2018 and 2019
I’m puzzled by the odd box shown in your screenshot.

Begin with a new empty model file and confirm all the Options settings are correct.

G2_001_Geo.skp (676.5 KB)

Thanks!! but all my files have same error. can you help me out for this file also.
bik.dxf (271.1 KB)

Here you go…

bik_001_Geo.skp (344.3 KB)

Okay thank you but its wierd how am i not being able to import.

Both of the above fail for me in SU 2019 and just come in as blank. They do however both import successfully in SU 2018.

I think the referencing blocks contained within the DXF are the issue in version 2019. It’s been reported a few weeks ago in this thread, team SketchUp are looking into it.

The workaround for now seems to be to explode the entities of the DXF prior to import into SU. I exploded both of your DXFs and they now import into 2019 without issue.

bik_IanT_Exploded.dxf (356.1 KB) G2_IanT_Exploded.dxf (1.1 MB)