Import COLLADA Model To Specific Point

import
collada

#1

Short: How do I get SU to respect the location of the model that is in the COLLADA file?

Longer: My software produces COLLADA files. I am in the process of updating my tutorials that show how to integrate them with models in various software. My customers have existing models that my output “plugs” into at specific locations.

It seems that at some point SU changed from respecting the COLLADA specification and the position of the model on import to importing the model and putting the user in a mode for them to place it manually.

This disrupts my customers’ workflow and makes the process much less efficient (actually impractical in some case) for my use-case. How do I get the old behaviour?

I looked everywhere I could think of. I would have thought the COLLADA import options would have a way to get this behaviour. (Actually, I would have expected the bahaviour not to change and the new behaviour to be an option, but…)

Thank you!

  • Andy

#2

can you attach an example of your ‘located’ export files…

john


#3

Sure. Thanks for the response John.

I’ve included the little room model and the file I’m importing.

Tutorial Files.zip (130.8 KB)

Here’s what I’m doing:

  1. Opening Tutorial Basic Room.skp
  2. Selecting File -> Import, choosing COLLADA, and selecting the other model (Tutorial walls.dae)

What used to happen: it would import it, make it a component, and place it in correct location in the upper-right corner of the room.

What currently happens: it changes my view by zooming into the model (which is super-annoying) and puts me in the mode to place the imported model as a component.

So I’m trying to find a way to get the old behaviour because the current one is not useful for my customers who use SketchUp.


#4

I can confirm it’s zooming and setting the cursor over the geometry which make placement confusing…

it’s a while since I imported dae files, and I don’t recall ever having automatic placement…

I think it’s having the axis remote from the geometry that causes the zooming…

john


#5

Thanks for checking it out.

It still modifies the view if the imported model doesn’t have any translation - which makes it super difficult to place an object at the origin in this model because the wall covers it.

The tutorial I’m updating was written using SketchUp 8 (!) - so 2012. I don’t remember the last version I tried when this was working - but it was certainly a post-Google SketchUp version.

Just seems like an odd change to make because it (seems to) completely remove a useful feature. Unless there’s something I’m not seeing?

On the plus side, this latest version is actually using all the colours in the dae (the old version wasn’t).