Icon for Kerkythea

I installed Kerkythea and even could manage to run it, but seems that I can launch it only from Finder. In the Kerkythea folder there is an icon, which launches Terminal window and with it also Kerkythea. But I can find no way to put Kerkythea icon on Dock. Kerkythea also does not launch automatically when exporting a scene as it should. Does anybody have similar issues? I can use Kerkythea as described, but it is so clumsy to launch it from Finder. Is this problem native to Mac OS? I use Mac OS Catalina now on iMac.

Hi Dan.
What do you mean by update? I opened my profile, but there is nothing to change, except that I use Mac also.

Your forum profile is apparently out of date or you need to add to it.
Screenshot - 2_4_2020 , 12_27_52 PM

Please also add SketchUp version and license type.

As for Kerkythea, have you tried asking on the Kerkythea forum?

Well I updated the profile.
Of course I asked the Kerkythea forum, but the most recent posts were from 2018 and said nothing about my problem. I found a complaint about similar issue in Sketchup forums (Terminal window appearing instead of icon), but no solution. I can use Kerkythea, as I mentioned before, but it is unconvenient via Finder. So I‘m just curious, should it be this way or am I just doing something wrong.
Thank you anyway for bothering to reply.
Jaak (that‘s my given name, alias Jabberwox).

launch from Finder >> Right Click Icon in Dock >> Options >> Keep In Dock…

does that help?


Thank you for your reply, but this is what happens: the icon on the dock is the Terminal icon. When I close Kerkythea and click again on this icon, it does not contain the same command that the icon from Finder does and therefore does not launch Kerkythea. I have to go back to Finder, launch Terminal from there again and copy its contents, then paste it into the Terminal in Dock. Does not make much sense. Terminal contents change, when I close Kerkythea. So I‘m in the beginning again. Weird, isn‘t it?

Launching X11 apps without the Terminal.app window is tricky and why I don’t use them any more…

it can be done, but the shell script needs to end with an & symbol to tell Terminal to be silent…

I’m running SU v20 on El Capitan a similar way, but it’s annoying…


I am not sure if this thread got resolved but I do have a similar issue, also on Mac and SU 2020.

I first tried running the Kerkythea program that I already had installed but nothing happened. It looks like I downloaded it in 2015 so maybe that should come as no surprise. I downloaded a current version together with the related extension. The extension put a series of icons in SU but they don’t tell you what they do when you hover over them and clicking on them does nothing. I assumed one would take your current drawing and open it in Kerkythea but I know that is just a wild guess.

Is there any advice anywhere about how to run Kerkythea on SU 2020 on a Mac? And maybe something that explains the icons too.

Screenshot - 2_12_2020 , 9_09_31 AM
Screenshot - 2_12_2020 , 9_09_41 AM
Screenshot - 2_12_2020 , 9_09_54 AM
Screenshot - 2_12_2020 , 9_10_04 AM
Screenshot - 2_12_2020 , 9_10_14 AM
Screenshot - 2_12_2020 , 9_10_25 AM
Screenshot - 2_12_2020 , 9_10_34 AM

How did you try running it?

Interesting that you do have popup boxes but maybe that is just on Windows?

I have now got rid of my previous folder with the earlier version but I think it looked similar to the one below. I tried clicking on what looks like an executable file called Kerkythea (I figured the clue was in the name).

Is this still live? Looks like the last entry was 2018.

I haven’t used Kerkythea on my ancient MacBook for years so my memory is rusty but I expect the exec file is the executable for Windows. I’ll try to do some hunting and see if I can find some useful info for you.

That makes sense in a way but if you download a specific Mac version, why would you get a Windows only file?

Anyway, thanks for your help as always.

I don’t know exactly how they have the Mac version set up anymore. Did you read this from the KT site?

For Mac, after downloading the dmg file, in order to install Kerkythea please drag and drop Kerkythea folder inside Applications folder. To run Kerkythea the first time, please right click and then select to Open the application. The following times, simply double click on Kerkythea file (inside Applications / Kerkythea folder).
Important Note for MacOSX Users
Note that for OSX 10.8 (or newer) X11 is also required, as it is no longer included with OSX (but X11 server and client libraries for OS X are available from the XQuartz project). Please find details and links here. Once you download and install it, please restart your machine (logout is necessary) so that X11 to be the default server.
Then, right click on Kerkythea from within the Applications folder. Click Ok to open it to the dialoge menu and Kerkythea and should be opened correctly.
Note that after upgrading your OSX version, downloading, reinstalling and running the server latest version once again may be needed for making it again the default server and allow Kerkythea to work.
In case you are epxeriancing issues with Kerkythea and Sierra version please upgrade to High Sierra.

I didn’t come across all that but I did download X11. I didn’t restart my machine and now I read all that, it looks devilish complicated. The comments about Sierra and High Sierra suggest this is all a bit antiquated.

Are Kerkythea and Thea different? I did notice a comment from @MikeWayzovski that Thea is now a subscription only service.

Thea is sort of the pro version of Kerkythea. It’s the one getting all the love these days. For a freeware renderer, though, Kerkythea is very powerful but like other programs, you get the support you pay for.