How to run testsup2 from command line on mac

I have tried this on a windows machine as well but with no luck. Sketchup will open but the tests won’t run.

One interesting find: Once I run the command, the SketchUp opens. Now when I select a template the test runs!

I even tried adding -template "path/to/default/template.skp" but that also doesn’t seem to work

Edit: I was able to open a file from the command line(via VSCode task) but the test still won’t run.

Edit again: I was able to open a template, run the test but the output is not being redirected to the JSON I have mentioned in the config.yml.

@tt_su did you get a chance to look at this.
I am attaching a screen recording for your reference

Edit: If you think there is a bug in testup, I will try to fix it. This is something we want as soon as possible.

Edit: Oh I see the branch you mentioned is not main. I will install the testup from source and check.

Did you have a chance to test that branch?

Yes, your branch is working.

1 Like