How to prevent files from opening in a newer version on Mac

I have this problem every update, it’s one of the reasons I generally skip a year, along with the pain of migrating extensions/styles/materials. I have not figured out a way to do it gracefully yet. I want to start playing with 2020, I am smiling from ear to ear about the new viewport controls within layout. No more “Modified” ever again, its a dream come true :tada:, Thank you Thank you!

But meanwhile I’m still in full workload in the middle of projects using Sketchup 18. I know I can have both running simultaneously on my machine. The problem I have is that once 2020 even exists on my hard drive, all Sketchup files start default opening in 2020. It’ll be weeks before I have all my extensions reinstalled and the toolbars reset the way I need and preferences, materials, bla bla bla, I just can’s start working in 2020. And even if I could do my work in 2020, I end up with a big messy mix of files of different versions.

Is there a way to suppress this behavior and force a Sketchup file to open in the version it was created in?

While writing this I thought I could move the 2020 app onto a removable hard drive so I can play with it but unplug when I want to do real work.

even with v20 installed, v19 is still my default, but it can switch if I open say 5-6 in a row in v20…

if this happens, I find a single ‘get info’ and set all to open with v19 will hold…

I have 5 versions of SU but only ever open those with ‘R-Click’ open with…


With Windows you can do the right click on the installer , repair option on an earlier version to set it as the default.
Perhaps a reinstall on Mac will do the same. But I’d listen to John as I’m a non Mac person.

1 Like

Fantastic, that did the trick. I specified 18.1 in a single Get Info window and clicked the Change All button to apply to all .skp. It’s holding so far with the 6 random files I tested with. I’ll be careful about how I open for 2020 to avoid a reset. Many thanks, you are on the ball as usual. :+1:

That is an oddity I noticed in the 2020 installer. All previous installers have a screen where you can choose whether to make this version be the default for those file types. After installing 2020 the owner of .skp was still 2019.

I think it’s due to the switch [back] to a java installer, not registering the new file type association…

you won’t believe how hard it was to get it running on [the now unsupported] El Capitan…