How to handle long faces with sharp acute angle?


#1

SketchUp seems to not hesitate a little bit while breaking up large rectangles into multiple faces with very sharp acute angle - this is a problem when I try to bake light maps with blender. The uvs of these sharp faces end up not occupying even a pixel on the image. This leads to cuts on the final rendered textures.

So, is there any way to stop SketchUp from triangulating the meshes the way it does?


#2

Could you describe the process by which you created your SketchUp model and if possible upload an example?

I’ve only seen SketchUp do this under two situations: 1) when imported data already contained such “splinters”, or 2) when an operation convinced SketchUp that the surface actually needed such thin triangles to represent it. In case 1), SketchUp is an innocent victim. Some other CAD programs create an output file that is already a triangular mesh full of “drunken spider” geometry. In case 2), this sometimes happens when the small edge of the triangle is subtly out of plane with its neighbors. This condition can result from various things ranging from a genuine non-planar curve with small segments to numerical effects during operations such as Intersect With or move with autofold to sloppy drawing, usually due to not using inferences well. Occasionally the adjacent “splinters” are actually coplanar but SketchUp failed to heal them. You can test this by deleting the edge between them and seeing whether faces are lost (you may need to turn on View->Hidden geometry to see the edges). In this case there are also extensions that merge coplanar faces for you - search the Extension Warehouse or sketchUcation plugin store.


#3

are you using the BlendUp extension to export to Blender?

john


#4

No John, I am using the Ruby API to extract vertices and tris from polygonmesh.


#5

I used to have an aunt with a face like that. The trick was not to stare directly at her for more than a second or two at a time.

-Gully