How to add Cubic Feet to Entity Info - it used to be there

Ouch … sorry to hear that.

Are the volume calcs the only real hang-up?
Is it a file you’re able share?
Could someone else annotate the model and send it back to you?

I’d be happy to help get you out of the woods.
Click my profile and send a PM if the file not something you’d care to share in a public forum.

Thanks, but I just need a solution, and I appreciate your trying to be that solution to my problem. I can go through and click each face and figure volume or even just use the Volume feature if it need. Let me see what comes up and if so I’ll send the file, if I end up in a conundrum.



I know absolutely bugga all about Mac but a shot in the dark, is it possible that you have altered the system font size and the dialog isn’t resizing to fit so the volume is hidden.

The volume should still be showing (screenshot from 2015 on my Mac).

I have seen some reports that somehow the middle part of the entity info window gets shrunken and then doesn’t show all the fields, but I thought a workspace reset would repair that. Failing the reset, try this: quit SketchUp, rename the preferences file to something else, then restart SketchUp (don’t erase the preferences file, keep the original as backup so you can rename it back if all else fails). The preferences file is at


Note: forcing SketchUp to create a new plist will lose all of your preference settings, but it should repair the size of the entity info window. If you are more of a power user you could compare the old and new versions and edit the value of the EntityInfoPanel_xxx settings so that nothing else gets lost. Also note that SketchUp must not be running when you fiddle with the plist - it will overwrite your changes when you close the app.

reinstalling wont help unless you uninstall everything first… are you sure you’ve reset the correct .plist? there will be multiple .plists for each sketchup install so if you have 2 sketchups installed, you’ll have 4 plists etc…

if you’re using 2014, this is how to reset the preferences:

• quit sketchup
• open (Applications/ Utilities)
• type or copy/paste the following in terminal then press <return>

defaults delete com.sketchup.SketchUp.2014

• relaunch sketchup

I don’t recall changing any system font size, but can look into it…

I will try this also, but it doesn’t seem to be the size of the entity box that is the issue. Although I did encounter this yesterday, where the box was cropped right thru the entity color box and wouldn’t even display the Name box completely, or the Type box at all. What is weird about that occurrence though, is that when I opened up the secondary criteria box, it was corrected (except that in SU 2015 I have never seen the Volume bar listed in my Entity box since I installed it).

Jeff, this is what I get when in Terminal:

farmhouse-mac:~ hardiebr$ defaults delete com.sketchup.SketchUp.2015
2015-02-17 09:15:38.565 defaults[1510:69369]
Domain (com.sketchup.SketchUp.2015) not found.
Defaults have not been changed.
farmhouse-mac:~ hardiebr$

I got the same response for 2014
what does this mean?

somehow you need to get rid of whatever plist Sketchup is reading then relaunch so sketchup will make a new one.

(quit sketchup first)
try going to ~/Library/Preferences
(that’s your user library… Not the macHD library)…

find all of the files which start with com.sketchup

what are they?


I can’t find a .plist for SketchUp, and I’ve uninstalled/reinstalled it
several times. Should I try deleting the SketchUp file from my computer
and download it again, and hopefully start over?

Thanks for all your help!

Do I need to make a .plist file for SU to put preferences?

Maybe it’s time to call on a Mac uber-expert.
You know, the kind of guy that wears a white lab coat … err … a white, umm … what is that thing @Marc ?

It appears that when I upgraded to Yosemite on my mac that a user folder wasn’t created it appears that it’s a problem with Yosemite I’m not sketch up I’m going to try to correct this problem and hopefully the program will work the way I wanted to stay tuned…

Have a great day!
Sent from my iPhone

That seems very strange! Do you mean that you have no home folder for the logged on user? I’ve not heard of Yosemite doing that.

Well it’s not that the folder wasn’t there it’s just that Yosemite hides it and I was able to find it and I did find a whole bunch of items that I deleted stay tuned…

Have a great day!
Sent from my iPhone

Do you mean the user’s Library folder? That has been hidden by default in Finder for a while, even back in the later releases of Mavericks I think. But I can’t imagine a reason to hide a user’s home folder. Also, that doesn’t explain why your defaults command failed to find the plist. It knows where to look despite the hidden status.

Keep us posted! The “Entity Info” panel does have some quirks that need to be addressed, but the strategies outlined here should cure those issues when they occur.


1 Like

to unhide the user library in Yosemite, go to your home folder in Finder… View-> Show View Options…
check the box ‘show library’

(this preference will only be available when doing the ‘show view options’ from the home folder)

All - a huge thank you and special tip of the hat to Jeff. I was able to find the folder in (MY LIBRARY!), it was hidden from know nothing’s like me. I erased all .plist items I had…all the way back to SketchUp 08!, Layout, etc., well I’ll be damned it worked!!!’

If I could buy you all a round I would…so cheers to you!

Appreciatively - Brad

Have a great day!
Sent from my iPhone

they’ve said why they did it.
to encourage developers to find ways to avoid users needing to go in there… plists etc are foreign to most people.
the ‘reset workspace’ or similar is the right answer in case recovery is needed since the user doesn’t have to leave the application to fix it but it doesn’t always work. (but really, it’d be best if the panels didn’t go wonky in the first place)

idk, personally, i’d rather the entity info panel stays as is until time comes for all of the Windows to be re-worked as one.

maybe drawing some sort of inspiration from apple’s …a sidebar or an inspector type of thing.