How do I draw a forearm?

This thread offers an alternate approach that is easy to implement.

I think Curviloft is a fantastic tool (as are the other goodies in Fredo’s vast toolbox). I generally don’t bother mentioning Spirix unless there is an additional benefit from using it. In this case, the OP wanted to smoothly transition from one shape to another. In your first example above, the interpolation is linear and is akin to auto-folding the top of an extruded cylinder (as Colin so neatly demonstrated). In order to form a more pleasing non-linear transition, additional information is required. In the case of Curviloft, this is supplied by the extra cross sections you’ve added in the second example above. The difference between Curviloft and Spirix is that one fits splines through the cross-sections you provide and the other creates cross-sections that follow a sinusoidal (or other) interpolation. While you can continue to adjust the cross-sections in Curviloft to get the shape you want, it’s a bit trial-and-error and sometimes you won’t see the (sometimes) un-expected results until it’s 3D printed.

I’m not here to participate in a PlugIns War. There is no Holy Grail. But the more tools you have in your toolbox, the more things you can do.

BTW, I’m curious how it would look if Curviloft used the sections in this model (I took sections of my shape at what should be “nice” control points for the splines):

arm2.skp (68.1 KB)

@jimhami42 there are many ways to model this, mine was a simple demonstration of how to use Curviloft in this specific situation, as it had been mentioned previously, not by me.
arm2curvi.skp (445.0 KB)

1 Like

I wasn’t trying to be argumentative, @Box … as you noted, there are many ways to model this. The one you created using my sections looks really good :slight_smile:

1 Like

Thanks, you guys. I want to do what you have shown me so well. I have downloaded curviloft and placed the rbz file in my sketchup plugins folder, but I don’t see it in any menu. How do I open it please?

I found out how to install Curviloft on my Mac:

  1. Go to and register for free at the bottom of the home page. Get your email confirmation, then log in.
  2. Go to Plugin Store Download | SketchUcation and press ‘Download Now’ near the top of the screen.
  3. In Sketchup, go to Sketchup>Preferences>Extensions>Install Extension, then navigate to the file you just downloaded and click it, then click Open, then Click Yes, then Click OK, then click OK. Its now installed without needing to turn Sketchup off then on again.
  4. In Sketchup, go to Extensions>Sketchucation>Sketchucation Plugin Store. This will open the store.
  5. In the Sketchucation Plugin Store window, search for ‘Additional Plugin Folders’ and click Autoinstall on the one from Fredo6. Then click OK. No need to reload Sketchup.
  6. In the Sketchucation Plugin Store window, search for ‘LibFredo6’ and click Autoinstall on the one from Fredo6. Then click OK. No need to reload Sketchup.
  7. In the Sketchucation Plugin Store window, search for ‘Curviloft’ and click Autoinstall on the one from Fredo6. Then click OK. No need to reload Sketchup.
  8. In Sketchup, go to View>Tool Palettes, then check that Curviloft is checked.

If anything went wrong, this was my summary of all the instructions I followed from, which took a long time to sift through and understand. I hope my summary makes it easier for someone.

Please note, there is a bothersome glitch in Sketchup that destroys the spacebar’s ability to shortcut to the select cursor. This problem came back after installing all these things. The solution is to hit the TAB key 3 or 4 times. Then your spacebar should work as expected again.

I am trying to use Curviloft now, but there are always twistings between the shapes. Anyone know how I can prevent this? Also, how do I film the screen to show you the problem? Also, since installing this, Sketchup keeps crashing (Bug Splat).

If you had done a search you will see that it’s YOUR ‘System Preferences doing this…’
Pressing Ctrl+F7 will toggle the behaviour…

Also, ‘Additional Plugin Folders’ is NOT required to run this plugin, and you now have two plugins folders to manage…