How can i transform a 2d image to a 3d model?


Dear sirs,
I download the extension, but when i used it and open bmp file nothing will be happen ,my file is something like this src="/uploads/default/original/3X/8/9/89444599862d7fe88b3fe406b7cbe37ddef38122.jpg" width=“450” height=“450”>
(but in the bmp format)
what should i do


dear sir ,
i download the extension ,
and run it ,
but after selecting my bmp file and opening it ,nothing will be happen,
my file is something like this


Does this extension not work in SU 2017?

When I try it it just thinks for a minute and then nothing, shift Z and nothing.


It works in 2017. If you can post a picture, maybe I can help you figure out why it’s not working for you. Also, if you open the Ruby console before running it, diagnostic and/or error messages should help to determine the problem.



This solution takes only some minutes, maybe it’s worth a try…


Hello I am having the same problem as Silverback above. In the Extension manager, it says the bmp tracer is Unsigned. When I click Enable - Apply Changes - then click out and try to import my bmp file nothing happens. When I go back into the Extension Manager the BMP Tracer shows that it is disabled…? In the extension settings, I have it set as Unrestricted. Any help would be much appreciated. I am trying to add our sign onto the side of the building.


When enabling the extension, are you hitting the “Apply Changes” button?


You can enable the ruby console and see if there’s an error message…


I’ve installed the BMP tracer and prepared a reasonable bmp file in GIMP.
As for some other users nothing seems to happen when I use the tracer…
Here’s the png version of the file I’m trying to import and push up into a hollow tubular shape.

Any help gratefully accepted by very old newbie…


The image you posted was a jpeg … I imported it into Gimp and converted it to grayscale. Then I used the threshold tool to insure that it was monochrome. I exported it as a bmp file, but Gimp chose to make it 8 bit instead of 24-bit (this may be the cause of your problem). I opened it in Windows MS-Paint and saved it as a 24-bit color image and it worked fine.


I’ve attached the BMP as a zipped file: (21.6 KB)

The imported results are in this model: shape.skp (142.9 KB)


This video may help …


Many thanks !
As soon as I watched the video I realized what was probably going wrong - I’d chosen a 16 bit output for my bmp file… (The file I uploaded had to beother than bmp “not allowed to newcomers”…
I’ll now have a look at the file you’ve done for me !
Once again, thank you


I don’t seem to be able to “push or pull” your image… The push/pull tool has a red cross with it meaning that it can’t work as I approach the drawing…
I’m using a free version of SketchUp make…
I’ve imported your zipped bmp (using BMP tracer) Same problem. Also, the middle is filled in and I don’t even know yet how to get rid of the filling !


Did you open the group created by the plugin so you can edit it?


Do you mean when using the BMP tracer? It creates a group ?


Yes. Did you notice when you select the resulting object there’s a blue bounding box around it?

Maybe easiest at this point to select it all and explode it.


I found the group commands in Edit - it works ! Thanks !


It sounds like you would do well to spend some time watching the basic video tutorial videos.


You’re right !