Hiding geometry inconsistent

Hi. I hid some lines from two curved surfaces (green arrows) using ‘SHIFT+Eraser’. When I click on my saved scenes, the lines reappear on one surface (red arrow) but not on the other (blue arrow). I this a bug or I’m missing something? Thanks.


You must update the scenes after hiding anything, using the eraser with Shift to hide lines is like right click on the edge and select hide.

Thanks. I have saved several scenes which are the final approved selected views for the project. Some views are from afar. Difficult to select the lines without zooming in (and losing the correct view).

I guess I have to select, hide lines, orbit/zoom to recreate correct views (which I’m trying to avoid in the first place) and then update scene.

You could also soften and smooth the edges, either by taping Ctrl with the eraser tool or from the soften smooth edges tray. You don’t need to update the scenes when you smooth the edges and in some cases, like yours, it looks better softening than hiding, when you hide an edge it is still somewhat visible cause it doesn’t smooth the surface.

I’ll give this a try. Thanks

I’m not sure I understand the problem - if your lines are within a group or component and you use Eraser + Shift or Option (I’m on a Mac) - I don’t need to re-update the scenes.

Do you have nested or double copies of that component or group?

3 Likes

Using the option key, Ctrl on windows, doesn’t require to update the scenes but using shift does. That’s if you’ve ticked the hidden geometry box on the scenes manager.

2 Likes

Strange - doesn’t do that on Mac… the video above I did both shift and option without updating the scene.

1 Like

Update. This method worked. I simply used Ctrl instead of Shift and I don’t have to update the scenes. Thanks for the replies. I learned something new.

Huh, let me get this straight: with Windows, when editing a component if you hide an edge inside the component then close the component and don’t update the scene the edge comes back? So if you hide edges in this manner inside a component, they are still visible in every other existing scene? That’s crazy, you have to update every scene, repeating the edge hiding? Sounds like a lot of work. I hope they never “fix” this aspect of the Mac version, they way they “fixed” being able to make new tags from the entity info box. It’s much easier to simply hide them and have them stay hidden.

1 Like