Hidden Lines and animation


#1

Hello,

I’ve just crated my first SU animation using hidden line geometry. I’ve installed a plugin for smooth transition animations, however the lifework is all quite poor and I’m not sure what else I can change. There are 100,000 edges and 50,000 faces - I’m not sure if this is considered a lot which could be causing issues?

Here’s a screen shot. In some areas the lines appear to be missing completely.

I’ve also attached a link to download the model. The layers aren’t working too well (I can’t create section animations) and there is still quite a lot more scenes to add.

I’d appreciate feedback :smile:


#2

Exactly which plugin?

-Geo


#3

Smooth step animation.

http://sketchucation.com/forums/viewtopic.php?t=13234

I haven’t exported with this yet since it requires the stitching of thousands of frames, but to preview the scenes within SU, it works very well.


#4

Thanks.
Looking at the model now…

-Geo


#5

There are forty-seven Styles saved in the file.
However, all eight Scenes in the model utilize just one Style; Straight Lines 01pix
That Style is not an ordinary Hidden Line Style but rather a Sketchy Edge Style.

Suggestions:
• Purge the unused Styles in the file. Window > Styles > Details (little blue arrow icon) > Purge Unused

• Purge the unused Materials in the file.
Window > Materials > Details (little blue arrow icon) > Purge Unused
Notice 59 materials were in the file before purge, but only 24 were in use.

It seems the Sketchy Edge style you’re using really isn’t the way you want to render the model.

Suggestions:
• Open the dropdown menu in the Styles Browser and select; Default Styles
• In Default Styles select Hidden Line style.
• Still in the Styles browser, click In Model to work with the styles in the model. (the little house icon)
• Right context click on the Straight Lines 01pix style you don’t want > Delete
• Still in the Styles browser, click Edit > Modeling Settings and deselect the display of Model Axes.

More in a bit…

-Geo



Hello again @aquariumdesign90

Given the state of the model, it’s apparent you’re not aware of how SketchUp’s layer system works.
SketchUp employs Groups and Components (containers) to isolate geometry.
Layers are an attribute assigned only to the containers which controls their visibility; nothing more.

Required Reading
Does SketchUp Support Layers? — SketchUp Help



Animation Resources:

Section Animation —SketchUp Help

A Round-Up of Scene and Section Animation Tips & Tricks — SketchUp Sage Site

-Geo


#6

Thank you!!!

That has fixed all of the issues I had. You’re right: I’m not using layers correctly… Force of habit from other software I think. I’ve watched the video and now have a better understanding for how it works.

I’m working on animating section cuts now… lookout for another post if I have issues!

Thanks again, I appreciate your help very much.