Hidden group can be seen through a 6mm panel

Cant get the file size to reduce.

What am I doing wrong I have deleted loads of the drawing and yet the file size remains the same. I have renamed it but still it is approx 14.5mb

Upload to 3dWarehouse then paste the link to it here…

john

Do you have images or materials based on textures in the model? They can eat up a lot of space fast.

6m x 4m Floor Area Test2.skp (178.0 KB)

I just copied everything and pasted into a new document, seems like extra information was being stored.??

To go from over 3MB to 178KB, yeah, it is safe to assume you had a lot of cruft you weren’t aware of!

How can I dump any information that isn’t required for the project Im sure loads of my drawings must be over size due to this.

You have primitive geometry (faces, etc.) from the panels associated with the Framework layer. They should be associated with Layer0.

I would like to say that makes perfect sense but Im stumped…

Ok I need to try something.

But although sounding like gobbledegook I have actually managed to separate it.

Thanks everyone.

Have you purged the file? (This removes copies of textures and images retained within the file but not in current use in the model.)

Window > Model Info > Statistics > Purge Unused

-Gully

You can open the panel group for edit and then select the contents. In Entity Info you will see that they are associated with the Framework layer. You can reassociate them to layer0. That will fix the issues with mysterious vanishing. If you back far enough away from the structure, though, the frame grid will still bleed through the panels. This is a limitation of the OpenGL display system. From far enough away, it isn’t able to calculate that the grid is farther than the panels, so it shows both.

Thanks Gully I will need to do that on a few of my files…

Ok All seems to be working fine and this solution solves my initial problem.

BUT now Im questioning why when I have my tolerance of units set to 1mm is the Geometry from behind showing through a 6mm solid panel. Was there a another way to solve this ?

I will definitely be using layers in the future.

The bleed-through issue has nothing whatever to do with your units settings.

The units you set in Model Info affect how SketchUp displays values, not how it captures those values internally. If, for example, you set mm with precision 1mm, that just means that values will be displayed in mm with no decimal places. It does not cause values to be captured in mm or rounded to whole mm internally (in fact, SketchUp internally captures everything in inches no matter what units you set). 100.25mm is still a legal value but will display as ~100mm. If you enable length snapping in Model Info->Units, new lengths will indeed snap to that unit where possible. But it isn’t always possible! For example, the 24 edges making the representation of a 100mm circle can’t be snapped to a whole mm and still fit the circle.

The bleed through issue occurs when OpenGL is calculating what is visible at each pixel on the screen view. It has to do this calculation based on distance from the camera position. When another entity is close behind a visible entity, as you zoom out (move the camera farther away) the relative difference between the distances becomes smaller and smaller compared to the distance to the camera. At some point, OpenGL is no longer able to tell them apart, so it displays both. In your case, this happens when the camera is far enough away that 6mm is negligible compared to the camera distance.

Most of the time, this effect is not a problem because you don’t view model objects from so far away - or when you do it is because they are small objects in a much larger model and you don’t notice the bleed because they are tiny in the view. The only possible fixes are to make the object in front thicker or to make the object behind not visible - preferably by making it a group or component and associating it with a hidden layer.

1 Like

Because it is actually the edges that bleed through and not really the faces you can hide the edges of whatever is underneath if you don’t want to put it on another layer.
Sometimes you want to see parts of the object that bleeds, so hiding it’s layer can be a problem.
I used shift with eraser to hide only the top edges.

1 Like

Hi Box.

That is a beautiful recreation of the original problem, giving a great visualization to Steve’s description of OpenGL Z-fighting, and a beautiful solution to the problem.

(I’ve been dealing too much with unintelligible handwaving trying to pass as technical explanations and it’s really refreshing to see something that is so elegant. Thanks.)

August

Hello August! Haven’t seen you around for a while…

Anssi

Hi Anssi.

Off topic reply continues in the Corner Bar: Dropping by to say Hi

August

Sorry been away. Thanks for that video nice of you to make the effort.