Help with the BUCKET TOOL

Hello everyone, I would like to get some help with the bucket tool.
Suddenly, after everything was working great, the bucket tool automatically turns to “match color of object in model” every time. even when I click on the ALT button. It turns to the bucket icon, but immediately turns once again to the “match color…”

I did a restart to the computer, I open a new file, and still the bucket tool doesn’t work.
does any one knows what could be the problem?

First question: Did you ensure that SketchUp has been installed correctly? That is, while signed into Windows as your normal user, did you right click on the installer and choose Run as administrator? Or did you just double click on the installer to run it?

Try the following:

Close SketchUp and LayOut if it is open.
Find the installer or download a fresh copy of it.
Right click on it and select Run as administrator.
When presented the options, choose Repair.
Let it do its thing.
Then check to see if the behavior of the Paint Bucket tool has changed.

Hey Dave’ thank you for your quick response.
I have the sketchup pro 2019 for a few month, and all worked great.
I open the program with “run as administrator”, I have rested the workspace in the performance also.

I’ll try the repair option that you have offered.
I’ll let you know!
thank you!

This doesn’t matter. Users who haven’t installed the program correctly report all sorts of weird behaviors sometimes well after they’ve installed. Windows updates can cause problems to pop up.

This is not the same as installing the program with Run as administrator. If SketchUp is installed correctly in the first place, you shouldn’t need to open the program with Run as administrator.

If you haven’t done it, you might as well download the current version; 2019.3; and install that.

I have seen this when other programs are active (Sonos, spotify)
When they try to message, the cursor of SketchUp sometimes started to change.
Does it still function as the normal paintbucket (ie not match color)

I worked!
I opened the sketcup instillation as “run as administrator” and choose the repair option.

and now it working!
thank you!