Help with hexagonal grid offset

Hi! Could anybody help with a bit of advice on how to offset edges of hexagonal grid faster? Look my gif. Shall I delete manually each nested edge? I was trying to use solid tools and clean up and scaled it to 100 times but no fine result. Sure there must be a quicker way to do it.

hex.skp (183.3 KB)

You might have started by just duplicating the holes, if that’s what you want. However you could delete the few remaining faces in the holes that you have, and use ThomThoms CleanUp to get rid of the extra edges (merge coplaner faces).

Extrude the hex and use outershell. Then if you only want 2d remove the rest.

1 Like

Yes, that’s what I was looking for. And I see it work’s fine in your case. But in mine each time I’m trying to use outer shell SU fails with error and exit application.

I used your model.
Check you graphic card driver.

I did a clean install of my GPU driver last month because as for me it’s quite often SU fails in some cases like this. But I thought it’s the same for everyone because of SU has some problem. But that clean install did nothing. then I tried to reinstall SU and still the same cases.

When you install SU do you use the Run as Admin method.
If not Go to the installer .exe and right click it and select Run as Administrator, then when prompted choose repair.

Yes, I did it with administrator rights… Don’t know what to do and how to get a technical report of this bug to show you. Maybe there with the technical report it would be easy to find out what’s wrong. I’m using the last version of SU on Windows 10. Do you use the same?

Yes latest on win10.
Are you putting your name on the bug splats so they can be identified?
If so perhaps @jody or @colin or another team member can look.

Thanks. I’ve sent right now a report “Crash Report #142414” and descrideb the problem and putted a link on this topic.

Just checking, ‘I did it with administrator rights’ is different to what I described.

Why? I have run install.exe with administrator rights and repaired SU

People often think being logged in as admin is the same as right click and run as admin. Just checking.

Aha, I see but did it exactly you said)

1 Like

Just back home and decided to test this scene on my laptop. So the problem still exist. But what I found. The problem occurs only when I create a grid with the help of “Comps To Grid Array” plugin as shown in the header GIF of this topic. I just made a grid manually and solid tool works fine (see screenshot). So could you please create a grid with that plugin exactly in my .skp file and say what’s your result? Thanks!

Sorry, I have no intention of installing a plugin that I don’t want and would never use.
How about you do it the other way, make a simple array and see if it works, thus proving the problem is the plugin.

I see and can’t insist on it). But thought it’s one of the most used plugins and probably everyone downloads it as it’s a part of JHS POWERBAR 2019. I just test it making a grid of squares and everything is fine with solid tools. Probably the problem appears only with hexagons. Please, could you try to extrude and then use outer shell in my another doc attached?

And once before an error, it showed me a notification something like “this action made a join of current shapes with hidden” yet I haven’t got any hidden geometry. Maybe the plugin creates some kind of invisible grid and when I try to use solid tools it conflicts and fails.hex2.skp (224.0 KB)

with all of the ‘User’ assembled Toolbars [like JHS] it is best to check for updates on the original extension developers version…

you can put them in manually or contact the ‘bundler’ to request they do that…


1 Like

I’ve known too many problems and not enough value to ever use powerbar.

Your model bugsplats for me too.
But if I use the component and place it in another model and array it it works without issue.
I suspect it is either the plugin or your settings.

Go to Model info Units and turn off Enable Length snapping and start over. You model doesn’t splat when I change that but it also doesn’t outer shell properly.
So by changing that setting before you draw anything I think you’ll find it works.