Help with 2020 on mac

serious performance issues with a new install of 2020 on my recently updated MAC

I have recently started using my SU pro 2020. I am operating a Mac running updated Mojave 10.14.6

my graphics card is
Chipset Model: AMD Radeon HD 7950
Type: GPU
Bus: PCIe
Slot: Slot-2
PCIe Lane Width: x8
VRAM (Total): 3 GB

tower info

Model Name: Mac Pro
Model Identifier: MacPro5,1
Processor Name: 6-Core Intel Xeon
Processor Speed: 2.66 GHz
Number of Processors: 2
Total Number of Cores: 12
L2 Cache (per Core): 256 KB
L3 Cache (per Processor): 12 MB
Hyper-Threading Technology: Enabled
Memory: 24 GB
Boot ROM Version:
SMC Version (system): 1.39f11
SMC Version (processor tray): 1.39f11

I upgraded the OS as far as it can go just recently in order to update SU and other programs, this is an older Mac Pro tower mid 2012. Having just been furloughed by Universal Studios I cannot afford right now to upgrade my machine…

I have been a SU user since 2006 and I have never had this behavior before… It is taking 45 seconds or more to pick a texture, It is taking 1 to 5 minutes to paste an object

I see on the forum people talking about an issues with 2018 and Mojave " my previous version being used was 2017.

I make large models set design for film and theme parks, the way this working it is unusable.

Can anyone tell me if there is some settings I should be adjusting? I received an email telling me I can update to 2021 would that solve any of this?

I have attempted 3 times now to contact support and I cant get past the captchka thing, some kind of error
hoping someone here can help

The processor isn’t particularly fast. It might be a video editing beast with 12 cores, but sketchup only uses 1 so it’s a bottleneck in your case. Add in other technology that is nearly a decade old and you’re simply not going to see the fastest performance.

Another factor is the model you’re working with. Try to model efficiently as an overly complex model will tax any system.

I started a new support case with you. I will email you now with some thoughts, but also carry on in this topic to see what suggestions you get.

Thanks for that…

Yes I know this computer was powerful 8 years ago right now I need to hold on till can upgrade probably moving to a PC

model sizes should be ok I am pretty efficient and the file I am testing right now was fine in SU 2017…

Your specs are not that different from my current MBP and I run 15,16,17,18, (skipped 19) ,20, and 21 just fine on Mojave 10.14.6. Must be some other problem, are you autosaving to or working with files which are hosted on a remote site, like Dropbox or Google Drive?

1 Like

I was last on 17 with Catalina then I updated to Mojave and installed 2020
I am hoping its not a hardware issue but I honestly don’t know what else could be.

iv’e been working a test scene for Twin motion I started in 17 on catalina after upgrading to Mojave noticed the performance issue

I then installed 20 thinking maybe that was the issue so far it is not…

file is 74mg was working fine before Mojave…

Files are all on disc no google drive or dropbox I have auto save set for every 25 min

It seems to be related to the selection of materials I just opened a much smaller file which was performing well until I tried to pick a material…

Hmmmm… I saw a speed improvement from 18 to 20, worked better on my machine. How about adjusting the settings in Sketchup>Preferences>OpenGL is maximum texture size on, try it off? You can try running with fast feedback on and off and also a lesser anit-aliasing. But honestly 5 min to cut and paste does not sound right. Can you post a file here on the forum that is giving you trouble, let me test it out.

FYI Twinmotion 20 is much much slower than TM 19 was, my FPS dropped from 70 to about 15, not great.

EDIT: Confused

Catalina comes after Mojave, if you upgraded from Catalina you went to Big Sur? Or back down to Mojave?

I will try what you suggest in the morning

sorry on os I got confused
I updated the os to 10.14 mojave so I was on 10.13 before running SU 2017 pro I noticed a problem after OS upgrade with 2017 and decided to
go ahead and upgrade to 2020 thinking might solve issue

This is my home computer I haven’t really been doing any serious work on it for last 5 years
and now trying to get it set up for work….

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.