HELP Trying to import a model to my workspace

sketchup

#1

So i am trying to import this model i need into sketchup pro but its not working. The model i am trying to get is this one Damaged city model. When i download it comes as a rar file i extract it what comes up is a whole bunch of JPEG files and a .mtl file. Please i really need help. This is the final piece i need for my school project. Thanks anyone help will be appreciated.
:slight_smile:


#2

Do you get an OBJ file? It looks like there should be one in the download.


#3

Nope I didn’t. I tried exporting it in Sketchup. After that nothing came up until i checked the folder and there were 4 3D objects. I think its 4 because i tried 4 times.


#4

I was looking at this on the page you linked to:

If there’s no OBJ file, I don’t see any other geometry file to import into SketchUp. I haven’t downloaded the file, though.


#5

Yep i know it says that but all i get is a rar file with a bunch of jpg and a mtl


#6

So there’s no geometry in the file? Then its no wonder have problems. You have to have some geometry to import or you’ll have to draw it manually.

Maybe you need to contact the author.


#7

Well… rip i really needed a destroyed city model in my project I looked all in the Sketchup work space but i couldn’t find any.


#8

Sorry. I don’t know what to tell you. Unfortunately you can’t import something that isn’t there.


#9

there are 3 .obj files in the .rar

john


#10

WHAT! Are you serious?
I downloaded three times to check if i was missing a file but nothing else came up


#11

what would be the purpose of my not being serious?

john


#12

I downloaded the file again its still not working is it possible for you to send me the .obj via email?


#13

Wait could the problem be my rar extractor?

Found the problem it was my extractor it was a bad one and didn’t recognize the obj so it didn’t include it.
But when I try to import it it still don’t show up.


#14

what are you importing the .obj file with?

I use MeshImporter by Jim Foltz from SketchUcation…

it doesn’t import the materials, but I was only trying to show the .obj exists in the .rar…

john


#15

I was just only using the export option in sketchup.


#16

but you need to import and there is no .obj import in the default formats…

you need to add an extension to import those files…

there are both free and fee ones available…

john


#17

If you are trying to get the OBJ file INTO SketchUp, don’t use Export. Use Import.


#18

But what do I import? obj doesn’t show up in the options the only time i see something in the folder is when i put “All Supported Image Types”.


#19

It doesn’t show .obj files because SU can’t import them. As recommended earlier, you need to use a plugin to IMPORT .obj files


#20

You don’t? then you can get one from the Extension Warehouse.