Having trouble opening Sketchup for Web

I have been using Sketchup Web Free extensively as I’m building a house. Yesterday when I tried to open the app in Chrome as I always do, it shows the red box loading icon but never loads. Just the red box. I’ve deleted all browsing history and deleted cache. Still never loads. Any ideas?

What version of Chrome are you using?

Version 83.0.4103.106 (Official Build) (32-bit)

Thanks for the fast response.

Hmmm… Someone else reported a similar problem earlier. I’m not seeing a problem but I’m on 64-bit Windows 10 and using a 64-bit version of Chrome. Do you have access to another computer you could try?

I do not tonight. But I did try my office computer today with Windows 10 and I still couldn’t open it in Chrome. I’m not sure of any other specifics of that computer right now though.

Perhaps @Mark will have some ideas when he gets online tomorrow.

Okay thanks

I tried Chrome 32 bit, and got an error, and the page never loaded. Then tried 64 bit, and the page loaded, eventually. I’m not sure why 32 bit Chrome worked previously, but maybe there was a recent change.

Here’s the error that happened.

webapp_gl2.wasm:1 Uncaught (in promise) RuntimeError: memory access out of bounds
at https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.wasm:wasm-function[18405]:0x7681db
at __wasm_call_ctors (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.wasm:wasm-function[316]:0x1056c)
at Module.___wasm_call_ctors (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.js.jgz:1:229341)
at func (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.js.jgz:1:26540)
at callRuntimeCallbacks (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.js.jgz:1:15996)
at initRuntime (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.js.jgz:1:16527)
at doRun (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.js.jgz:1:283262)
at run (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.js.jgz:1:283541)
at runCaller (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.js.jgz:1:282441)
at Object.removeRunDependency (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/webapp_gl2.js.jgz:1:17713)
at e (https://app.sketchup.com/prod/2020-07-15--17-01-59--f4bd191/static/sketchup-app.js:1:418890)

I’m facing the same issue since 15/07/2020.
Windows 7 Pro 32bits
Chrome 83.0.4103.116 32bits too
i3 with 4gb ram

Others have confirmed that using 64 bit Chrome does work. I have alerted the web app team about the sudden change for 32 bit Chrome users.

So now that I’m at work I tried loading Sketchup free for web again, and it won’t load on my work computer with Chrome but it is working with Micrsoft Edge.

Win 10
Chrome Version 84.0.4147.89 (Official Build) (32-bit)
Microsoft Edge

Hello Everyone! The team has identified the issue affecting our 32-bit Chrome users and are working on a resolution. We will be releasing a fix as soon as possible.
Thank you for bringing this to our attention.


it’s working fine now on 32 bit.

thank you.

It’s working well now. Thanks team

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.