Hardware accelleration problem

I have Sketchup installed on my laptop (Samsung NP305E7A-S01NL).
When I start Sketchup the screen is gray and not displayed correctly. (

)

Then I turned off hardware accelleration in SU, which resolves this problem, but then selecting becomes very slow.
I have been trying to update my graphicdrivers, but that doesn’t seem to help.

Hope one of you can help me further with this problem!?

That’s typical of GPU drivers that don’t have good support for OpenGL. Radeon GPUs are notorious for poor OpenGL support unfortunately. If updates to the drivers don’t help, look into replacing the graphics card if possible.

@fcr25 What graphics driver version do your have ?

[wiki] Where to find Hardware Graphics Info for your SketchUp forum profile


FYI the graphics driver page for AMD legacy GPUs:
http://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows+10+-+64

You can go with the released WHQL Catalyst driver, or the beta Crimson driver.

Hi Dave,

Thanks for your reply. I already put my graphic crad info in my profile.
It’s a AMD Radeon HD 6520G.

Try updating your graphics driver as Dan advised. If that doesn’t help, you could try uninstalling the 64-bit version of SketchUp and installing the 32-bit version instead. It has helped some AMD Radeon graphics users.

Also, check in the AMD control panel 3D settings that SketchUp is set to use your graphics card instead of an integrated Intel chip. Automatic selection often doesn’t work. I think that the checkered background is often a problem with those integrated graphics chips.

Anssi

Hi Anssi,

I tried the 32-bits version, but that didn’t do it for me. I guess I have to live with no hardware accelleration and therefore slow selecting.
thanks for your help.

regards, fcr25