Guidelines Not Working

I pressed control, guidelines are checked, and shadow guides show but they don’t stick. Any thoughts? I have a PC

I expect you have guides disabled. Look in the View menu. Is there a check mark next to Guides? If not, select it. You’ll likely need to update the style, too.

Thanks! it started working!