Gray or Black rectagles appearing randomly on surfaces

Does anyone have any idea what are these rectangles and why are they appearing? they seem to appear only when something is not selected and disappear as soon as I click something. this is all new as I use sketchup for over a year on this laptop and never had this problem. This is Pro2020, btw

Share the .skp file so we can see what you are working with.

Sketch1000.skp (15.6 MB)
This is the file, is just something new I started on, but is quite strange with those rectangles, they aren’t clickable or something

I don’t see anything like that when I look at your model on my computer. There are a lot of incorrectly oriented faces in your model. They should be corrected but they wouldn’t cause anything like you show in your screen shot. Maybe it’s a graphics driver issue. You could update the graphics drivers directly from the manufacturer.

It would be a good idea to use some groups and components. Also purge your model of unused stuff.
Screenshot - 7_17_2023 , 12_32_15 PM
This reduced the file size by over 75%.

Sketch1000 purged.skp (3.9 MB)

1 Like

Thank you so much for the advises, Dave <3 will do correct all the faces in the model, i just wanted to have all the bases done. still struggling on the components, most of the time i have flashing surfaces like disappear from the view, but found the fix to that :smiley:

Is strange because my graphic card shows to be up to date. I have to graphic cards actually second is Intel HD graphics 630, but i have manually routed sketchup through nvidia cause is much better. maybe i should reset settings… this is the only project i see this on.

What did you look at to confirm that the graphics drivers are up to date? Don’t trust Windows to tell you that. Go to the Nvidia site and get the latest drivers for the card.

i checked the latest one installed in driver version in Device manager and checked nvidia’s website. Last installed 23.06. 2023 released driver, that’s the same on nvidia’s site. I don’t trust windows on that :face_with_hand_over_mouth: they’re a bit… way behind with how fast stuff is released by manufacturer. Intel is also up to date as well. maybe if i copy the project like… dunno upload it and delete it from my pc and redownload it may help? …

Do you still see the rectangles in the copy of the file I uploaded?

Unfortunately yes :frowning: the black and gray rectangles are still there

Try powering the computer off and back on. Then check again.

What does it say when you open [menu] Preferences > Graphics > Graphic Card details?
It should mention the version number from Nvidia instead of a date in Device manager.

One could also toggle some settings to see if anything changes.

Did that, still the same, it looks like not there at first, but when i start zoom in, it appears

Definitely a grphics/display issue on your machine.

Hey Mike, all i see is this:
Open GL: 4.6
Version 536.40
same with the one on nvidia site. i have the Geforce app to detect any new graphic driver updates. so is up to date

or maybe is a problem with the project… i see those only on this specific project. have no issues with others

Maybe but if that was the case I ought to see it in your model, too. I don’t.

Strange it is, I had that happen to me once. 2 items I had deleted in a previous session would appear in the render. If I remember correctly to make them go away, I copied the model an pasted it in place in a new instance of SketchUp and saved it under a different name.

1 Like

I just tried that, but it didn’t copy one of my groups, so i went out and didn’t save, now I’m back to the project version Dave uploaded and i can’t see the rectangles anymore :face_with_peeking_eye:
I went back to my previous project too in the 2020 app version and is no more :face_with_open_eyes_and_hand_over_mouth:
I guess it was a glitch or something? it lasted for a few days, almost a week now.

Must have been a glitch i think, on my end only, since you couldn’t reproduce it. it seems copying it and trying to transfer to a new project worked the magic to it going away
Thank you so much for all the help~

1 Like

Guys i get that a bit when sending multiple scenes and creating multiple pages to layout from Sketchup using PlusDesignBuild or PlusArchitect plugins. There’s a bug with SketchUp and Nvidia which is a pain in the bum.