Graphics glitch?

Here’s something I’ve never had happen before, and I use Layout pretty much all day every day. When I zoom out to 96% or smaller on this drawing, the whole window (page and greyed area) covers with hatching, zoom in and it goes. Hatching is on a layer - turn it off, makes no difference. Four other pages in the file are not affected. I made a copy of the file and deleted all the hatching - no difference. If I click on any part of the drawing, it will delete an area of hatching, but if I zoom in and out again it reverts. Note the hatching corresponds with an area of hatching I have on one wall. Any ideas on how to resolve?

Looks like a graphics driver issue. Can you share the LayOut file so we can try it out on other machines?

Odd, it’s never happened before and nothing has changed in my set up for ages. Here’s the file (just one page). I use these hatches all the time without any issues. I’m using an imported .dwg survey as a base and I have had odd artefacts in SketchUp before exporting to Layout. Possibly something to do with it, although it doesn’t happen on the other same base drawings.

Well, I don’t see that hatching at all here on my PC. When I first opened the file it looks like this:

Zooming in and out makes no difference.

As I said, I suspect it has to do with the graphics drivers.

Did you delete a bunch of stuff from the document before uploading it?

The title block and the other pages. This is the problem page and it still does it on this stand alone file.

I noticed a whole lot of references which purged out since they weren’t used in the file.

Just for grins, take your stand alone file and purge the unused references. Is there any change in the behavior?

On my file, most of those red files are blue, with a few red, but I purged and updated them and the behaviour is the same.

They are only red on my end because I don’t have the original references on my computer.

I’m back to your graphics drivers as the problem.

I would agree but I have numerous other drawings using the same hatches without any issues. There is nothing on this drawing that I haven’t used numerous times before. Can you export it to a dwg and see if there are any hidden layers or oddities?

Here’s the DWG. I don’t see anything that looks like the hatching you are seeing across the entire page. Maybe your file has had something corrupted. Copy the content to a new document might fix it. It does seem to be a system related thing, though.

graphicsglitch.dwg (116.3 KB)

We have a check in place that fixes incorrect geometry in our 2019 release, where invalid paths (or paths with only 1 point) could hang around and cause havoc with files. This is what is happening with your file. I see this issue you are referring to with LO 2018.

You have two options
#1. Upgrade to the current 2019 This will fix this issue and also comes with same great improvements. :slight_smile: Release notes

#2 Delete the bad path…

  1. Crossing / or Window select all visible geometry
  2. Rt click, select Move to Layer -> Hatches
  3. From the Layer dialog lock or turn the visibility off the hatches layer
  4. Press cmd+a on the keyboard
  5. From the Shape Style inspector notice that an object is selected and indicates a Pattern Fill is applied.
  6. Press the delete key on the keyboard. - The Pattern Fill should go away.
  7. Turn the visibility of Hatches back on (you can move this info back to the original layer)

Trent

2 Likes

Brilliant, thank you! That fixed it - I couldn’t see any object with cmd-a but the hatch fill was indicated as being applied and so was deleted. I do have a license for 2019 but haven’t got round to moving across/up to it as yet. Perhaps I should!