Got my print settings in an odd state and now Sketchup keeps crashing

#1

Following on from my last post where I have been learning about printing to scale (thanks for your help with that Dave), as I was playing, I managed to make the unit field “blank”.

When I try to select something, i get the option of feet/mm/inch/cm, etc… But when I select something, Sketchup crashes:

I don’t know how I got it in this state and thats not my question… Is there a way to reset the settings in the hope this brings “Inches” back?

Edit… Managed to do it to the Height field now.

sketchup%20print%20crash%203

I just typed a space in the field… And now my Width and Hight have no units… And when I select one from the list Sketchup crashes…

0 Likes

#2

Yes this is a bug (in Sketchup 2017 at least)
To reproduce the problem

Open the Print dialog
Deselect Fit to Page
Navigate to the Width Units field
Enter a space character
Close the dialog and then restart Sketchup
Open the Print Dialog and attempt to set the Units back to Inches
Sketchup Will Bugsplat at this point

The Fix is to edit the registry and set the Width or Height units to 0x00000000
The registry keys are
HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2017\PrintOptions\widthUnits
and
HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2017\PrintOptions\heightUnits

The attached .reg file will reset the necessary registry entries. Just delete the .txt from the end of the file name
Su2017 printer settings FIX.reg.txt (336 Bytes)

1 Like