[Google Earth] Movement trail artefacts when import model from SketchUp

Hi there,

apologies if this has been answered before, I conducted a search but couldn’t find any past threads.

I downloaded a model from 3D Warehouse, then sited it on imported ground from Google Earth. The problem I’m having is that I have “trails” from where I moved the model to site it properly that are showing up on Google Earth after I export the model.

How do I get rid of the movement trail artefacts? Or not create them in the first place?

Hi @devaldivia, welcome to the forum!

Your best bet for an answer will be to post an image (screen capture) of what you are seeing, or share the model you have created. Either can be added to your reply using the seventh button above your reply (Upload button).

I agree with @TheOnlyAaron that we need some more info to understand what you mean. It sounds like possibly the imported model is “sticking” to pre-existing geometry and dragging bits of it along. But that would depend on the workflow you have followed, and at this point is pure speculation. Another completely different speculation is an OpenGL artifact due to issues with your graphics adapter or its driver.

Edit: @devaldivia please fill in your profile so that we can base replies on what OS, SketchUp version, and graphics system you are using.

Thanks guys for the tips. I’m new here and all tips are appreciated. Here is a a screen capture of the model imported to GE and the artefacts. I outlined the artefacts in red:

Here’s my info:
Graphic Card: NVIDIA GeForce GTX 970M
Operating System: Windows 10 Home
SketchUp Make/Pro version: SketchUp Make 2016 32-bit

I followed the work process here, with modifications as this was for a prior version: http://masters.donntu.org/2007/fvti/grischenko/library/lib_8.htm

Thanks for the help!

Can you please post the SKP model in this thread ?

It looks like it is actually geometry that is hidden in SketchUp, but then shows up as visible in Google Earth.

Here it is.

Oh, and when I exported, I did make sure that “Export Hidden Geometry” was Not selected under “Options.”

LVL project3(1)-2.skp (305.1 KB)

Those edges are in your model. You don’t see them when looking at it, though, because you’ve turned edges and profiles off in the style.

I expect they are the remains of moving some of the geometry but not all of it. If you moved it with the edges turned off, it would be easy to miss selecting everything.


You can see where the originate in an X-ray view.

And when you’ve fixed it, it’ll look just fine in GE.

1 Like

Thanks Dave, that worked!

Per your suggestion, I turned on Edges and Profiles.
Then, instead of clicking/dragging to select, I Selected All with Ctrl+A, then de-selected the terrain.

This solved the problem.