Glitch with creating Dynamic Components

mac
dynamiccomponents

#1

Occasionally I try to conquer Dynamic Components. They are like the north face of the SU Eiger! Sometimes I win the battle but mostly DCs whip my ass.

The problem I would like help with today is working out why it seems to be impossible to add attributes for sub-
elements of this ohsosimple model. I mad a DC earlier that worked just fine. I have tried starting over but I haven’t tried closing SU and re-opening (or the old fallback of switching off my Mac and powering up).

I’m guessing this may not be an issue with the file so it may not be possible to replicate my experience.

I was able to add user defined attributes for the top level of the DC.

Test.skp (215.1 KB)


#2

Your “sub-elements” are groups, not components. Attributes can only be added to components!

Open your top level component for editing. Right click on each group and choose “make component”.

Just noticed you tagged this for Mac. Not sure if the above paragraph is correct for Macs - unless you’re using a 3rd party 3 button mouse!


#3

Your paragraph is fine. Apple brought out two button mice around 2005. You should probably say context-click though as if you’re left handed (or just prefer it) you can change the primary mouse button from left to right. Even before Apple sold them, you could control-click to get a contextual menu.


#4

I can add parameters to groups just fine. I prefer groups to components as DC parts because it lessens the clutter in my In Model component browser, and I have seen weird behaviour when a component has been used both as a part in a DC and outside of it.


#5

I was not able to reproduce any errors. Try again with the Ruby Console open and see if any errors are displayed there.

The latest version of Dynamic Components is 1.5.0 - is this the version you have installed?


#6

Of course you can add attributes to Groups


What is the point of attributes attached to **groups**?
#7

The glitch is very odd. I found that it only occurred when I was trying to add groups of attributes (like all three Position attributes in one click). If I selected them individually, it worked normally. If I chose the group, they didn’t appear under the element but they did disappear from the selection list. Closing the DC Attributes window and re-opening it did sometimes restore things in the selection list. That’s how I know individual selection worked. Even more peculiar is that, when I first started selecting attributes yesterday, I could choose groups without problem.

I don’t know which version of DCs I am using. I didn’t even know there were different versions! I am running SU 2018 Pro on a Mac. Have DCs evolved? They were introduced to great fanfare some years back but despite being really quite beta to use, they look the same to me as they did at the beginning.


#8

Open the ExtensionManager window, then click the > button on the right of the Dynamic Components extension.

DC’s have not really evolved over the years - there has been a handful of bug fix over the years but nothing new or improved.


#9

Looks like it’s version 1.5.0. If that’s old, doesn’t the system inform you there is an update available?


#10

I’m surprised! I started a new thread on this:


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.