Glitch in new dashed line feature?

I’m playing around with the new dashed line feature of SketchUp Pro 2019 (trial) and ran across an anomaly.
I have a plot plan for a house. I drew the underground utilities (e.g. water, cable, electrical, etc.) and put them on a separate layer. I set the default line style for that layer as “dash-dot-dash”. The utilities that I drew as straight lines show the correct line style but the utilities that I drew as curves (2 point arcs) either show as solid or as long dash curves. So effectively, there are three line styles for that layer. I only get a consistent line style when I use the dotted line style (or a solid line).

Has anybody else seen that? If it is a bug, how do I report it?

Without trying to re-create what you describe, I’m betting that you’re expecting the curves to be unbroken lines, dashed as you’ve specified. However, SketchUp actually does curves as a series of straight lines.

And I’m guessing that each of those lines “restarts” the dash pattern, so if you have very short edges in your curves, the dash pattern won’t look anything like you expect.

Just a guess.

1 Like

Yes this is a known limitation with the way we draw Arcs and Circles that you have brought up and sjdorst has explained it correctly.

We are tracking this issue internally.

Trent

I have been able to draw curved dashed lines without a problem. At least I used the line tool and drew some curves and, as I said, they worked fine. I will try drawing an arch and see what happens.

BTW: Were all of those lines the same type of dashes and on the same layer?

sjdorst,
That’s an interesting point. After reading your reply I tried zooming in and out and lo and behold, when I zoom in the dash-dot-dash pattern starts to appear on the curved lines. And as I zoom out, all the curved lines go solid whereas the dash-dot-dash line style for straight lines remains consistent regardless of zoom.

So I guess the trick is to either stay away from curved lines or be careful of the zoom if you want to use the new dashed line feature. I haven’t tried it in Layout yet.

Okay, thanks for jumping in. It sounds like something that may get “fixed”?

The reason I used curves for some of my lines is because I’ve never been able to get a smooth curve with the freehand tool. Maybe my hand just isn’t steady enough (wish there was a smoothing function). Anyway, even when I tried a short S curve with the freehand tool, I still got inconsistent results with dashed line style.

ntxdave,
I’d buy your theory about the “dot” getting lost except that doesn’t happen with straight lines, the dot still appears regardless of zoom. I think sjdorst had the right answer when he/she pointed out the segmentation of curves throws a monkeywrench in the works.

If you look at my image below, all of the lines were drawn with a different tool but all have the same dahed line style applied to them, If you look close, each of them is drawn correct (correct dashed line style). The problem is that when you use one with a dot in the pattern it is/can be so small that you cannot see it unless you get up close (zoom in).

Dashed%20Lines

I do not think there is any bug based on the fact that SU draws curved lines (drawn with tools other that the freehand line tool) as segmented lines. The problem is the size of the dot compared to the overall size of the image.

Could you try to “explode” the curves and then select all ( both curves and straight) and “weld” and see if the dashes conform to the newly formed line?

Did not save the file but I will go try again and see what happens…….give me a few minutes.

long nam,
I found the “explode curve” tool but where exactly is the “weld”? (I’m just getting my feet wet on the expanded features of Pro)

I use TIG’s Weld plugin……….

Here is my test for you………each line and arch was drawn independently and then I use TIG’s weld tool and notice that they are now all connected (welded) and the dashed line pattern was maintained. In fact, if you look carefully in a couple of places you will see that the solid part of the pattern was maintained in the weld process.

Welded%20Dashed%20Lnes

ntxdave,
Haven’t used any plug-ins so that’s a new area for me, perhaps in the future. Your picture looks good but what happens when you zoom in and out?

it’s a plugin, not part of the SU tool set. You should be able to find it in the extension wharehouse, there are a few, smustard is one i use

The pattern of the dashed line shows just fine unless you zoom out so far that small segments (like dots or very small dashes) are too small to be distinguishable. This is a standard aspect of SketchUp regardless of the item.

As an example, if you draw a circle with say 16 segments. It might look fine given the current fov (field of view) but as you zoom in, you will see that the 16 segments more clearly. As you zoom out, the 16 segments are smaller so it looks more like a smoothed circle. Again, just the standard way SU works. This is not something new to the dashed line concept.

Okay, thanks. To keep things simple I may just go with a dotted line instead of the dash-dot-dash. All I need at this point is something I can use to distinguish underground utilities.

I’ll consider this thread closed and thanks to all who jumped in to help.

are you exporting these to dwg/dxf… can I suggest you avoid dotted linetypes [and hatches]… I banned them from my Autocad office , particularly with the complex linetype scale options in autocad… nurmerous times lines went missing cause someone used imperial defaults in a metric environment. try and find the dots when they are 25.4 times further apart…

and lets not talk about exploded dot hatch patterns :frowning:

used linetypes with dashed lines in them…

:grinning: :+1::+1:

gsharp,
No, I just need to create PDF files for on-line submittal to get a building permit.