Generate report error..Help required

I’m commenting as the 2nd party in this (I’m IT and it is one of our Designers who is actually is having the issue). User is having the same error. He’s running Windows 10 on a fresh install of Sketch Up Pro 2018 in New York. Error appears to come from 3Dwarehouse.sketchup.com. He’s not using any components from the 3D Warehouse and is using our in-house designs which are all dynamic components.

When he goes to File > Generate Report the javascript error comes up and he can go no further. He did mention that at one point SketchUp crashed and he sent a bugsplat report to SketchUp and THEN generate report worked, but the next day when attempting to run a report again, it failed.

I will point him to this thread and see if he may be able to assist if you still need to do a live session with someone. Hopefully this helps

1 Like

Just got bitten by the Generate Report bug. Based in US. Windows 10 Home. Like someone else experienced, I had a bug splat at one point and Generate Report worked during that session but not afterwards. I’m pretty much dead in the water as far as productivity is concerned, and highly frustrated. I’ll keep checking here to see if there’s any resolution.

How are you using the generate report, with a self made template? Or are you manipulating the standard one?
When offline, Generate Report uses the old version, it will need some extra spreadsheet work, but at least you have something…

From one of our PMs: “Our current theory is that there’s an issue in the web service that GR is contacting. This issue unlikely has anything to do with 3D Warehouse other than the GR application is hosted there. One possibility we need to eliminate is that the user is using an older version of Dynamic Components, even though they’re reportedly using SU 2018. Could you ask them to verify the version of Dynamic Components they’re using by going into Extension Manager and expanding the extension info?”

Would the users affected mind taking a screenshot of that and posting it here, please? Thanks!

I am at a loss. One of my older drawings is still not working to generate a report, but I just did a quick drawing today and now that model WILL generate a report. I have attached the screen shot that you requested. Both of the said drawings have the same dynamic components.

Hi - I’m a developer. Can anyone who’s still seeing the error clarify something for me?

Are you all seeing the same JavaScript error? “frontend is not defined”?

Or are any of you seeing a “sketchup is not defined”.

Thanks for any info,

error

Ok, we believe this is a caching issue caused by a bad deploy a week ago. We will have the issue resolved on our end within the next 2 hours.

For those of you who are blocked, you can try the following workaround (for SketchUp 2017 and 2018):

  1. When you see the JavaScript Alert, click Ok, but don’t close the generate report dialog.
  2. Right click on the blank dialog, and say “Show DevTools”.
  3. Within the DevTools, click on the Network tab, and then “Disable Cache” (see screenshot).
  4. Once the cache is disabled, trigger a reload with a Ctrl-R on Windows, or a Cmd-R on Mac.

Let me know if this works. Again, we should have it fixed on our end without you doing anything in the next 2 hours.

Thanks!

2 Likes

Looks to be working for me now without taking the extra steps. Thank you for the help!

2 Likes

Thanks so much, @ross! You solved that in half a day, that’s awesome! And thanks to all the users who gave great feedback, it was all helpful.

2 Likes

Yay!!! Problem solved. Thanks to everyone involved in the rapid resolution.

I have a problem with the Generate report. I have sketchup Pro 2016 and windows 10. I solved the problem with a right click on the stuck reports window . A menu appears on the jammed report window. I selected “Update” from the menu . I tried everything with i18n.dat but no one helped. 2021-10-14 20-33-44.mkv — Yandex.Disk

Please do not double post.