Free web - Constantly having my entities disappear. Have to undo

I’ve used sketchup in a hobbyist form for years now. I was on Make desktop, but decided to try the new free web version. I’m plagued with disappearing entities. Typical scenarios:

  • Select COPY. Start dragging copied item. Drop it. Looks good … and, GONE. Just gone. Hit undo and it re-appears.

  • Choose an item from the warehouse. Drop it. Looks good. … 1 second later it’s gone. Hit under and it’s back.

  • Select MOVE. Start moving. Somewhere during the move it just disappears. Hit undo.

Happens every session, many times per session.

What browser are you using?

Chrome.

Before you execute the Undo action, what does the Edit menu display for the Undo function’s name? SketchUp (for the desktop, I’m not sure about for the web) dynamically customizes the text for the Undo and Redo functions to include a brief description of the action that will be undone or re-done. If you can check the Edit menu between when the object has mysteriously disappeared and you perform the Undo action, there may be a clue as to what is happening. (If the web version of SketchUp does not dynamically customize the Edit menu text, then this won’t be helpful, sorry.)

Thank you for your ideas. I was just able to reproduce it in a crazy few actions. Copied … dropped. Waited for maybe five seconds and watched it go boom. There is no apparent context visible, or as a tooltip to see what action the undo command would be reversing.

Are you using any non-default tags?

And what is set as your Default tag? Do you see this in the Tags window, with the pencil icon beside Untagged?
image

I can easily reproduce this (though it may take a few tries) by either using Ctrl+c/Ctrl+v or Move/Ctrl/Click and drag …

To make things interesting…

I can even get it to delete the original object if copying with the Move+Ctrl! So … I copy/drag a copy of an object to another location and release it. Everything looks fine and BAM! Both the copy and the original disappear.

BTW - my workaround for this craziness is to hit just watch for this every time I copy and if it happens, hit Undo and then save.

Again, this has NEVER happened to me with the desktop version in years of use.

You are still not giving us enough clues to help you work out what is happening. Either post a video of some sort, or upload a model in which this is happening, please.

And you didn’t respond to my earlier questions about tagging in your model. A screenshot of your Tags window might help.

Any issue in Web can be down to simply needing to reset your cache and cookies/website data. Or, switch to a different browser to see if it reproduces.

Bear in mind that your recent files list and any recently changed hotkeys or settings live in browser website data and are only updated to your account on the server periodically (based on my testing at least). You can try just resetting cache at first if you are worried about rolling back any recently changed hotkeys.

One thing that would suggest a cache/cookies issue is if you reproduce the “dropped” copy in a setting where the component is the only item in the model, then perform Select All and see whether entity info says you have selected one component or two.

I forgot to answer the tags, but it’s irrelevant because I am using zero tags. It’s untagged.

Respectfully, I’ve given you everything that I can, because I’ve described basic functionality that should obviously not be failing. Having said that, I will try to upload a video of it happening. This is how easy it is for me to reproduce. I created a new file, added a single box hit V+Ctrl, dragged a copy and waited. In this case it didn’t disappear, so I simply moved the copy again, wiggling it. BAM … they both disappeared.

And Brian … to make this more enjoyable, I just went back to the window, which had just the figure and hit Ctrl+A. She was selected. The moment I opened the Entity Info window, she disappeared! Selecting items, copying them, moving them… something super sketchy is going on!

perhaps you have actually signed up to SketchyUp Web

Maybe I should try to unsubscribe from that nonsense!

I’m afraid I have no idea then, why the program is failing on you.

Can you try another browser - perhaps a recent version of Edge? Does that exhibit the same problem?

Have you tried the ‘magic cure-all computer fix’ - restarting your computer from cold (close down, switch off, then restart)?

Firefox and Safari are both known to have minor problems with SU Web, but Chrome is usually the best choice, Edge a good second provided it is fully up to date (older versions had problems).

Is Chrome fully updated?

One other thing that just possibly might help before trying a full cold reboot is to clear your browser cache.

If none of those work, then I’m out of ideas - I don’t recall seeing anyone else report this problem, though there is no doubt it is real.

To be honest, I didn’t expect a solution. It’s too weird of a problem and I found zero mentions of this scenario before I posted. I just figured I would log my experience in case anyone could chime in.

The only reason I’m even trying the web version is because my work laptop won’t let me install the desktop app and I spend 99% of my computer time using that machine. I will just have to walk all the way into the other room to use my home laptop!

Thanks guys!