FredoCorner Bevel issue

I just tried to bevel the edges of an octagon and i got an error that says ‘reference to deleted Entity’.
I’ve never had any issues with octagons and FredoCorner before. here’s the .txt file it generated.
Did i do something wrong or is this a bug?

Ruby Error - FredoCorner Bevel - 03-Apr-23 18_01_27.txt (901 Bytes)

Shre the .skp file and your settings for the bevel so we can see what’s going on and help you out.

it does what i want it to do if i do each corner individually but not if i do all of them at once.

the shape and edges selected

FredoCorner settings:

.skp file
shed2.skp (5.0 MB)

edit: hit undo a few times and now it works and i can’t re create the issue.

I don’t even see the hexagonal shape in your model. While I was looking at it I did a little poking. I note that the faces in your terrain are reversed. Should be white front faces up.

There are a few other reversed faces that ought to be fixed, too. I also fixed incorrect tag usage and purged unused stuff. All edges and faces should be created and remain untagged. It’s a good idea to purge unused stuff periodically to keep your model clean, too.
Screenshot - 4_3_2023 , 8_35_02 PM

Screenshot - 4_3_2023 , 8_35_19 PM
File size reduced by 62%.
shed2 purged.skp (1.9 MB)

1 Like

Wow! I didn’t know unused components took up so much space. nor that i really had any to worry about. I also know pretty much nothing about tags so if there were any they were either mistakes or things from deleted warehouse models.

hexagonal shape was off to the side of the terrain a little bit. I think i accidentally gave you the skp file before saving it. I’ll remember to save next time. the issue isn’t happening anymore so all is good.

Thanks a lot!

1 Like

Take some time to go through the instructional materials at

1 Like

will do.