FredoCorner -- An Error Occured in the Ruby Code

Previously, I had been using Fredo Round Corner to generate chamfers on my drawings. I just discovered Fredo Corner – with the ability to undo chamfers – and tried switching over to that.

When I attempt to chamfer my model with it, however, I am getting a ruby error. I’ve pasted the generated text below. Hoping someone more knowledgeable on this front can help me out.

Date: 10-Mar-20 08:56:10
An error occurred in FredoCorner
An error occured in the Ruby code

undefined method `’ for nil:NilClass

fredocorneralgo.rbe: 2314 – brane_free_chemin
fredocorneralgo.rbe: 2059 – block in catena_process_branes_protected
fredocorneralgo.rbe: 2045 – each
fredocorneralgo.rbe: 2045 – catena_process_branes_protected
fredocorneralgo.rbe: 2007 – block in catena_process_branes
fredocorneralgo.rbe: 2006 – catch
fredocorneralgo.rbe: 2006 – catena_process_branes
fredocorneralgo.rbe: 965 – block in solid_construct_branes
fredocorneralgo.rbe: 964 – each
fredocorneralgo.rbe: 964 – solid_construct_branes
fredocorneralgo.rbe: 919 – block in solid_reconstruction
fredocorneralgo.rbe: 918 – each
fredocorneralgo.rbe: 918 – solid_reconstruction
fredocorneralgo.rbe: 883 – solid_add_remove_edges
fredocornertool.rbe: 1821 – selection_change
fredocornertool.rbe: 1809 – selection_add_remove_edges
fredocornertool.rbe: 1832 – selection_set
fredocornertool.rbe: 1515 – block in preselection_instantiate
fredocornertool.rbe: 1512 – each
fredocornertool.rbe: 1512 – preselection_instantiate
fredocornertool.rbe: 1507 – preselection_analyze
fredocornertool.rbe: 745 – activate
fredocornertool.rbe: 190 – select_tool
fredocornertool.rbe: 190 – launch
fredocornertool.rbe: 174 – action__mapping
lib6plugin.rbe: 126 – call
lib6plugin.rbe: 126 – launch_action
lib6plugin.rbe: 224 – launch_action
bootstrap_fredocorner.rbe: 103 – launch_action
bootstrap_fredocorner.rbe: 118 – block in startup
lib6plugin.rbe: 1274 – call
lib6plugin.rbe: 1274 – command_invoke
lib6plugin.rbe: 1256 – block (2 levels) in build_config_commands
lib6traductor.rbe: 1372 – call
lib6traductor.rbe: 1372 – block in add_command
SketchUp: 1 – call

Did you also download and install the latest version of LibFredo6 and then restart SketchUp? If not, it seems likely that the new version of FredoCorner you just installed requires a newer version of LibFredo than you are running.

I did do both, yes.

Seems to be working now, however. Not sure what I did between it not working and it working to make that happen, but happy to be moving forward with modeling.

you probably re-started SU, which the library needs…

john