Forgotten preferences etc.on Startup?

sketchup
#1

We’ve recently upgraded to 2018 in our office and I’ve noticed that every time i startup Sketchup is like my first time!

Things i have to do each time I open a file/the program:

  1. I must agree tick the user agreement
  2. Untick “open on startup” on the “getting started” window that comes up on your first sketchup use.
  3. A few of my Tray settings have gone/new ones appear that i have got rid of before.
  4. Many of my plugins have to be re-attached to the toolbar at the top (these are floating on startup)

I have a template file, which seems to be all opening ok (viewing style, shortcuts etc) just literally the 4 things above dont remember? Ive tried to amend and save over my template file, but this doesn’t work.
this feels like it may be a file saving/internal network type problem. If so is there anything I need to be asking my IT department to sort to resolve this?

thanks!

#2

It sounds like you may not have write access to some of the folders where preferences are stored. If you can, right-click on SketchUp and choose Run as Administrator. If SketchUp is pinned to your task bar you can right-click on the icon (before opening SketchUp), right-click on SketchUp in the menu you are shown. Then you should see Run as Administrator.

If that fixes the problem you can ask your IT to give you better privileges, so that you don’t have to run as admin every time.

#3

Thanks for the reply Colin. I ran as administrator and it didnt fix anything… still have to sign agreement etc.

i will contact my IT dept. :frowning:

#4

It should be installed using Run as administrator (context click on the installer file and select Run as administrator.) in the user’s login to Windows.

#5

@DaveR what should be installed using run as admin; Sketchup? I presume it was. Sketchup is working fine, just those few issues.

#6

Was that true after quitting? It would be bound to ask you again the first time you ran as admin, I was hoping that would get the files written correctly, then the next time things would have been remembered.

The two places where preferences are stored are here:

C:\Users\YOURUSERNAME\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp

and:

C:\Users\YOURUSERNAME.AM\AppData\Local\SketchUp\SketchUp 2018\SketchUp

You could look to see what the modified dates are on the .json files.

#7

SketchUp needs to be installed under your normal login, by right clicking on the installer and selecting Run as administrator. Most things will work fine in SketchUp without this but some things don’t there are plenty of posts here in the forum which show this, including the type of behavior you reported.

Note: This is not the same as having your IT department log into your computer as the system admin and installing it. It needs to be done under your login so that Windows grants permission to SketchUp to write the required files when you are logged in.

#8

@colin I dont have both those folders? Or at least i cannot see them in app data?
I think ill speak to my IT dept mentioning what both you guys have said.

Thanks!

#9

@DaveR Ok i will check with IT if they did it this way.

thanks!

#10

Good luck.

Assuming they didn’t, which would not be surprising, have them tdo it or grant you temporary admin rights so you can install software under your login. Then right click on the installer, select Run as administrator and if presented with the option, choose Repair.