Follow-me feature does not work properly

I tried to create a quarter sphere by first creating a trace (to be followed) then create the surface to be ‘swept’ about the vertical axis. But there’s a unwanted geometry at the top of the quarter dome. Can’t figure what went wrong. Please see attached image showing unwanted geometry.Thanks for your feedback on this.

Follow Me actually does work correctly but your setup for a quarter sphere is wrong. Follow Me requires that the first segment of the path is perpendicular to the profile and the extrusion will end perpendicular to the last segment which is exactly what your screen shot shows. Since you aren’t setting the first segment of the path perpendicular to the profile, Follow Me projects (it doesn’t rotate it) the profile to perpendicular. To create the quarter sphere, you need to set up the path correctly. The easiest way is to use a circle instead of an arc and then divide the edges at midpoints 90° to each other.

I’d argue Follow Me is indeed broken for not recognizing the arc curve as an arc, and internally calculate a normal vector for the end vertex that is perpendicular to the radius.

7 Likes

Thank you Dave. Unfortunately I tried the method you’ve suggested but still was not able to resolve the issue with the ‘weird’ geometry at the top of the dome.What did I do wrong? Attached is an image showing the steps I took. (as a new user, I am blocked from uploading more than one image at the time). By the way, I’ve just started to use Sketchup today (I am still mispronouncing it “ketchup”!). I’ve been using Pro-E and Solidworks >10 years, but am feeling quite frustrated with Sketchup.

You didn’t divide the edge of the circle at the midpoints along the edges. You divided at the vertices so you wind up with the same thing you got before.

To make it easy, draw a default 24-sided circle at the origin, select it and rotate it 7.5° so edges cross the red and green axes at right angles. Look at my screen shot from earlier for reference. Set up your profile along one of the axes and run Follow Me.

Have patience with SketchUp. It’ll come and you’ll get the hang of it.

FWIW, when you are dragging out the radii for circles, make sure you are dragging them out on axis so vertices are aligned on axis.

Thanks again Dave. Now I’ve realized what you meant in the first reply and gained a little better understanding of how Follow Me works. However I can’t seem to figure out why I get a hollow quarter dome instead of a solid even when I started out with an enclosed surface. Follow Me also would not work if I group the surface that’s used to create the quarter dome. This is my third day using Sketchup and I already feel like uninstalling it off of my computer. hollowquarterdome

That’s looking better. I don’t know why you are getting the missing face at the end. I bet it can be fixed by tracing one of the edges with the Line tool.

The difference with @DaveR model is you have added lines going toward the centre of your path.

Geometry in SU is sticky, so when you touch them together they stick to each other, but if you touch an already completed surface, it can break that surface when you meet another line (the follow me form meeting the lines going toward the middle of your path).

Welcome to the SketchUp Forums! This is how I model a quarter sphere.

  1. Draw a circle
    C = circle command
    Arrow keys = chooses axis to draw circle on
    17%20PM

  2. Draw another circle from the center point

  3. Select & delete inner face. Draw a circle from the center point.
    44%20PM

  4. Select path & use follow me
    16%20PM

  5. Delete path
    56%20PM

  6. Turn on hidden geometry (view menu -> hidden geometry), parallel projection (camera -> parallel projection) & from the top view select 3/4 of the sphere. Delete it.
    39%20PM

  7. Enter front view and delete 1/2.

  8. Draw these 3 lines, then you’re finished!

21%20PM

I think this is similar to what Dave was explaining.

2 Likes

I use the same approach. For full circles Follow Me does produce a correct result, and you end up with vertices being on the exact radius as was defined by your profile.

1 Like

Thanks all for your help.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.