FlatText missing from Extension Warehouse

Found some broken links on the EW site. When using my usual bookmark for FlatText’s page I get a blank page instead.
I can get my other extensions’ pages OK, but the links from those pages to FlatText also take me to a blank page.
In addition, I cannot log into my EW account. When I try, I just get dumped back into the page I started from, with the “anonymous” icon in the upper-right corner.
I recently updated FlatText - perhaps that triggered the bug…
Any other developers seeing this?

This link is working now. Was it the same link as you tried? Did you try searching for the extension by name?

https://extensions.sketchup.com/extension/6363ea88-3cb4-4801-813b-eb199e2de9b3/flat-text"

Nope, still getting a blank page.
Tried logging in with my Windows machine and it works OK, so maybe a Mac bug…

I’m on a Mac - so not a general Mac thing. I’m on a 2015 iMac 27" 5K machine, running latest version of Mojave. Haven’t yet moved up to Catalina.

And the link above still works for me, even after after I clear my cache.

Odd, if it still won’t work for you.