Failed to save document, Pro 2018


#1

SketchUp Pro 2018. Windows 10 Pro

I looked up the responses to the same question for others with the same issue, but I’m unable to resolve my “failed to save document” situation.

My file has imported DWG 3D, I suppose I should start with since it can potentially create issues. The file is about 51 mb by now, 2.5mil edges/1.3mil faces. Autosave is disabled but backup file is not. Last save was about 4 hours ago; I opened the same file with the earlier timestamp and it did not open as a read-only, even though I assumed it would as I already had it open. There is one backup file and three tmp files. I have tried saving to both a network drive and a local drive, same outcome. I also tried converting my whole model to a component and did a “save as” for the new component, but no new file appears in the save location (also tried both local and network locations).

I think I can just move objects from the latest to the earlier timestamped file for now, but I hope I can get to the bottom of the error so that I can figure what I did wrong and avoid in the future.

Thanks in advance.