Extra lines when using the follow me tool

I have been creating 3D models of water towers for about 10 years with no issues.
I’ve always taken the height and width of the water tower and made a rectangle with the exact height and half the width.
I’d import an image from the blue print of half the tank.
I would then outline the image, remove all of the lines that don’t pertain to the tank, create a circle at the base of the water tower outline, and then use the follow me to extrude the image.
It’s worked perfectly for 10 years, but now all of a sudden it’s throwing in a ton of extra lines wrapping around the tank that aren’t supposed to be there.
This has only started happening the past few days.
When I trace the outline, there are only 3 lines for the ball section; two arcs and a straight line.
Does anyone have any idea why these extra horizontal lines are showing up?
I understand the imagine is still showing the blueprint through on the exterior of the model, that always goes away once I start designing the colors scheme and logos.
I have redone this model 30 times and they keep showing up.
Help!





Right before performing the follow me…check to see that the arc at the top of the water tower ball is still an arc. (Not reduced to segments)

Can you upload the model itself, to add to the images you have already uploaded?

It might be easier to work out what is going on from examining the model, not just from the images.

Are you still using SU 2019 as shown in your profile, on Catalina? Or has something changed recently in either the version of SU, or an update to your OS?

Sorry, I guess I need to update my profile.
I’m running Skethcup Pro 22 on an M1 Mac with Monterey.
I will upload the model in the morning when I’m at the office.
Thanks for the response.

Why are you using the imported image as a texture on the extruded water tower?

Regarding the exploded curves with Follow Me, Eneroth AutoWeld will automatically weld edges during Follow Me and might be quite useful here.

Hi John,

I am uploading two versions, the outline and the expanded version of it after I used the follow me tool.
Let me know what you think. Thanks.
Water Tower Expanded.skp (3.7 MB)
Water Tower Outline.skp (347.1 KB)

Not sure. It’s the way I’ve always done it and has worked quite well until this project.
As far as using Eneroth AutoWeld, I’m not sure what that is. I’ll have to look into it.
Thanks for the reply.

There are a few issues with segments. You need to be aware of the segment count in your curves. Something you have done, perhaps too many segments, has exploded your top curve into it’s individual segments. Note the smaller curve is continuous, despite the overkill of 100 segments for such a small curve.
Using appropriate segments counts and welding may be all you need to move forward.
GIF 16-07-2022 12-06-11 AM

1 Like

As @Box has already said, the principal problem is ‘too many segments’, amplified by having what were two or three arcs exploded.

But simply welding your outline edges alone will also fix the visual issues.

Can you tell by looking which of these FollowMe results is based on your original outline, welded, and which uses 12 or 6 segment arcs, with a 24 segment circle as a path for FollowMe in both cases?

Water Tower Outline JWM.skp (2.0 MB)

1 Like

Thank you guys so much.
That makes perfect sense.
Not sure how the I ended up with 100 segments on the arc.
Box, Thanks for showing me the welding tool.
That will definitely come in handy.
And John, no, I cannot tell the difference between the two.

The one in the right is from your original profile, welded.

Have a look at my model itself, turn on hidden geometry, and you’ll see the difference.