"Extensions " missing from top menu bar

Well, I tried to find an answer to this in the forum and found a thread “Extensions menu missing”, tried everything they suggested and, when I use the Extension Warehouse to try and add a plug-in, I get a message saying that there is an “Invalid Signature”. So, I check my the permissions in my plug-in folder (by the way, I’m trying to get podium installed on my desktop Mac Pro) and it’s all good there.This was in the Sketchup Plugins folder in the Library.
I’m at a loss right now so if anyone could give me a clue how to resolve this I’d be very grateful.

There is no Extensions menu until you install an extension that is set up to appear in it.

What plug-in are you referring to?

What version of SketchUp are you using? Please complete your profile.

Okay, so I’m using Sketchup 2019 and I’m trying to reinstall my Podium plug-in.
I’m on a Mac Pro, macOS Mojave version 10.14.6 if that makes any difference.!
here’s the message I get.

Get the latest version of Podium from the source. Do not install an old version.

You should always use the latest versions of any Extensions.
However, having an ‘invalid-signature’ message is not necessarily fatal !
Sometimes Extensions have simply not yet been updated and re-signed, but they will still work with newer SketchUp versions.
If your Extension Manager > Extension Loading Policy is set to be ‘Unrestricted’ even those ‘unsigned’ ones will load - or at least attempt to load if they are truly incompatible with the newer SketchUp version…

Hi Dave,
This is why I’m so frustrated, I just pdgraded to version V2.6. See attached invoice and the plug-ins menu in my Sketchup 2019 folder in the Library. Sooooo confusing!

You probably should remove the screenshot of your invoice since it has your license number on it. Everyone will use your license.

Have you restarted SketchUp after installing it?

Will you please complete your profile?

Hey there Dave,
I have restarted Sketchup but to no avail. I appreciate the advice on removing the
license but I don’t know how to do that. I filled in as much of my profile as I could but did not understand the “profile” items. Are they necessary?
I should also mention that I have Sketchup 2019 installed on my laptop as well (same operating system) and I have the new Podium installed there as well. The sketchup on my laptop has the extensions menu and I can see the podium menu bar but it’s not loading any content. Maybe that’s a question for the Podium people but, maybe it’s related.
I’m pretty much dead in the water here.

(Edited your post to remove your license information)

1 Like

Many thanks!

Are the System Settings the same on both machines?
Firewall might be blocking things.