Exporting to DWG Changes Drawing Size

I have a drawing I did in Sketch Up Free version and saved as an .skb file. All is good. Upgrade to Pro, opened up the file to edit, still good no issues. However when I export to dwg the drawing shrinks a bit.

I tried camera > parallel projection that didn’t do anything. I’ve tried both 2D and 3D exports, still the same. I can’t see any options to change scale or anything when exporting.

For example my x axis dimension in the skb file is 14" but the dwg is 13.227. The drawing is just simple 2D.

Any ideas what I am doing wrong?

FYI: the Sketchup using .skp as a file extension. .skb is a backup file: The backup file is the previously saved version of the file and lives in the same folder as the model file. See more here:
Setting Software and File Preferences | SketchUp Help


For exporting, check this article:
Importing and Exporting CAD Files | SketchUp Help

1 Like

You also need to set the alignment, if you are looking down on it you should set it to Standard Views/top

1 Like

Thank you. That was a typo on my part. I meant .skp. Looks like that link has my answer as well.

Thanks. This did it. At first I did top and my drawing disappeared since it’s 2D. Changed to front view and it’s sized perfectly.

Does that mean when I was doing the drawing it was set at a slight angle or something?

You have been drawing your plan on the red/blue (xz) plane that in CAD and SketchUp is usually seen as the “front elevation”. The red/green plane (xy) is what usually represents the “ground plane”. If you develop your plan into a 3D model this might lead to some clumsy navigation so perhaps you should rotate the plan to the “correct” position.

Probably what was at a slight angle was your viewing direction.

1 Like