Exporting is causing holes in the part

Ok, the last few days i have been testing some things out before posting.

Here is what i jave found out.

I am on the newest version of su pro

I create a complicated part with some curves etc. Solid inspector and entity info state it is solid and has volume, indicating it is solid and manifold.

I export to stl, obj, or dae and import into solidworks, fusion and freecad, all of which report no volume, broken faces and edges.

Somehow the exporting process is breaking my parts, causing me to have to fix them in order to print or do other types of things.

It seems anything with follow me, or cutting a ring out of a hex shaped cylinder causes issues when exporting

What could be causing this?
Anyway to export the part better?
Would exporting as quad faces be better? If so, what extension?

Thanks for the help.

Can you share the file so we can check it?

1 Like

How large are the objects you’re modeling? Are you modeling for 3D printing? Are you doing what we’ve talked about numerous times in the past and modeling as if millimeters are meters?

1 Like

Yes, i made sure i modeled in meters to prevent tiny face issues.

Yea, i can do that. Give me a few to get back from church :slight_smile:

1 Like

large mask solid for testing1.skp (1.2 MB)
this is just one of the many that fail.

this was modeled in meters, so its very large.

thanks

Im thinking its just the nature of stl and mesh exportation.

i have read that exporting with quad faces is better than triangles. Does skecthup have that ability?

Since Francisco is volunteering to help I’ll leave it in his capable hands. I just exported your model as a .stl file and opened it in the slicer. No errors or indications anything needs to be fixed.

2 Likes

I wonder why freecad, fusion 360 and solidworks all report major errors?

freecad shows all faces inverted and empty of volume, once flipped, its still no volume

fusion shows same thing and no positive volume.

i have to repair the missing faces in both freecad and fusion.
I wonder if cura is auto repairing it upon import for you?

I opened you test file in Sketchup > exported to STL > imported to FreeCAD. All is good. When you have a moment will you pleased upload one of your STL files that appears to be faulty.

1 Like

I exported it and opened with Cura and I have no issues with the file, if you want to print it, is there a reason you need to export to other softwares before sending it to the slicer?

1 Like

Yeah, i need to do fem testing on it.

Large breathing mask solid.stl (726.4 KB)

freecad reports empty and inverted normals

fusion 360 reports empty and holes in mesh

the stl i uploaded is the one i exported from the sketchuip file i sent you

I was able to complete an analysis of you model in FreeCAD 0.20.0. And you are correct in stating that the faces are reversed in your STL export (I don’t know what’s up with that!).

Things to do.

Firstly, the model is way too complicated. So let’s reduce the number of faces.

  1. Install the universal importer and enable the toolbar in Sketchup. The icon is a lavender swan.
    Universal Importer | SketchUcation

  2. open the SKP model

  3. click the Universal Importer button. You will specify that we want to resize to 5,000 faces

  4. place the new geometry in the model space and delete the old geometry.

  5. orient all of the faces so they pointing out. This is the command in the right click context menu.

Second, Use a different STL exporter

  1. Download and install the Sketchup STL exporter from GitHub - SketchUp/sketchup-stl: A SketchUp Ruby Extension that adds STL (STereoLithography) file format import and export. and use that one for your exports.

Lastly, the instructions for working with the STL in FreeCAD

  1. Watch this video https://www.youtube.com/watch?v=6OhXCmVM3Ks&ab_channel=schmidtcr
    Here are his comments from the more info link below the video:

I struggled to get the FEM to run on an STL with errors like: “GIVING UP” “Mesh Not Available” “only surface mesh, no volumes”

Here´s what worked for me
first I had to create a simple STL of exactly the feature I was interested in, then:

In FreeCAD:

  1. Open STL
    Part Menu
  2. Create mesh
  3. Create solid part from mesh
  4. Copy + Refine part
    Part Design Menu
  5. Create Body (Blue Body - not yellow - Button)
    FEM Menu
  6. Add analysis
  7. Select body-Create Mesh
  8. Add Material
  9. Select body-Add Forces
  10. Select simulation - Run simulation
  11. View Simulation results
2 Likes

yes, that is the video i found a while back to try this out with haha. Great video. Thanks for posting it as well.

I ended up decimating the mesh in freecad to 4999 faces, but it still has errors, even after repairing.

So i am guessing i need to decimate the mesh in sketchup first, since that is the native software i used to create said mesh.

The copy, refine part option in freecad, causes major issues, even with a decimated part, again, probably since i decimated the part in freecad rather than SU.

when you said “first I had to create a simple STL of exactly the feature I was interested in, then” are you speaking of the dust mask i made? or something else? i have gotten freecad to work with simple parts from sketchup exported as stls, but as soon as i do something even slightly complex, it fails. Such as this anchor post i modeled. It was done in meters, its solid, but freecad and fusion360 have errors, especially on the pipe type feature.

image

thanks for your help

i will try those tools you speak of today and see what happens

Speaking of the mask model, there is some geometry in the Sketchup model that is causing the STL exporter to generate a few very small triangles (image below). Reducing the polygon count with Universal Importer will remove these problem areas in the first pass since they add so little to defining the overall shape of the object. I do believe this will turn out to be the root of the problem.

1 Like

ok, so even in meters, it has generated some tiny faces due to having so many faces in the first place. interesting.

im testing out the universal importer now. So far so good.

A little more digging and I see that there is in fact an error in the STL file. This STL file was created with the online Sketchup App.

1 Like

Interesting, yeah, if you use blender, you will find i think i broken faces and a few other things when analysis is used in blender.

I dont know why freecad on your end didnt find them?

So something is happening when its exporting the file.

I really hate triangles sometimes haha. Really wish SketchUp had some basic nurbs functions so we could at bare minimum export as a step file for 3d printing or fem analysis

Thanks for helping

Aha, a change of the setting in FreeCAD resulted in a couple of faces being identified as SNAFU.