Exporting 3D Models Does not Work

Expecting great things, I have just upgraded to the Pro version and installed the current SketchUp Pro 2016 (16.1.1449 64-bit). An attempt to export even a simplest box (rectangle, then push-pull) results in no errors, but no export file is being created. This is regardless of which export format I select. It doesn’t matter if I choose 3ds, Collada, or AutoCAD, the same thing happens, namely nothing. :frowning:

AJ

Do you get any error messages or pop ups? Also, saying just in case, make sure you select your directory in the Export Settings window.

Sorry, but I said “no errors”. That means no errors or popups. The export directory in settings is irrelevant: this is just the default. Every time export is requested, the “Export Model” dialog shows up allowing one to select the destination folder. Regardless of whether I select a non-default folder, or leave it at the default preset, the same thing happens: NOTHING!

AJ

Further information:

Attempting to import a 3D model (3ds or Collada) brings up - after some churning with a progress bar - an “Import Results” dialog, again, with no errors, and messages like “3ds Entities Imported: Materials: 12, Nodes:0, Meshes: 81”. The dialog has only one button: “Close”, pressing which invariably brings up a standard warning dialog with a very helpful “Import Failed”. message - no other information can be seen.

Note: I am able to import an AutoCAD file. It’s the 3ds files that I am most interested in that I can’t.

AJ

what are your import units set at?

try metres if you haven’t already, you can always re-scale after if it works…

john

3DS is in many ways an antiquated file format. There is a size limit, file names, especially textures, should follow the old DOS 8.3 format, with no non-ASCII characters. Are there non-ASCII-characters in your folder names or user name? Also check your export options, especially how groups and components are treated, and triangulation. Checking the “export standalone edges” box produces a zillion unnecessary thin faces etc.

Just suggestions

Anssi

1 Like

Let’s regroup here - we seem to have drifted off topic. I cannot export anything 3D - period. Any suggestions?

The folder name is d:\Projects\Sketchup, i.e. no strange characters in there.

Having spent $800 I would expect the basic functionality like that to work.

AJ

It will work, given a chance…

The folder you specify D:\Projects\Sketchup
First does it already exist ?
If not make it and retry.
Now does it have FULL read/write permissions for all listed users, seen/set under Properties>Security>Edit ?
If not then perhaps you, OR perhaps even SketchUp itself can’t write any exported files into it.
Can you export a file into say C:\Users\YourUserName\Desktop ?
That should be the least restricted location…

Also backtracking to the start and perhaps a more likely suspect…

When you installed SketchUp did you do it by double-clicking the installer’s exe icon.
This is known to cause weird issues with many setups.
Having Admin powers as an ordinary user, is NOT the same as actually being the Admin.
The recommended way to install is to select the installer’s exe icon and
right-click>context-menu>Run as Administrator...
This will then install SketchUp and its components with the necessary permissions.
You could try uninstalling SketchUp via
Control-Panels>ProgramsAndFeatues...
Then reinstalling it in the correct way…
Any customization like personal Extensions should survive the process…

Once you have SketchUp definitely installed OK, then try exporting again…

1 Like

TIG,

Thanks for your suggestions, however…

The folder definitely exists. I have read/write permissions to it (can easily create and edit SketchupProjects in it). Regardless, I tried exporting to C:\Users\MyUserName\Desktop and C:\Users\MyUserName\Documents and got the same results: NOTHING gets created. I definitely have read/write permissions to those folders…

Why doesn’t Sketchup tell me that it has encountered a problem saving the file?

I’ll try to re-install Sketchup the way you suggested and we’ll see.

Thanks,
AJ

TIG,

So, I have re-installed SketchUp as administrator, as you suggested. I am even running it as administrator, just in case. The same result: NOTHING happens. I cannot export a 3D model. I get no warnings or errors when I try.

This is very frustrating, needless to say.

AJ

I agree…

Over to the SketchUp tech-guys…

:unamused:

I have submitted an official tech-support ticket - two days later, I have yet to hear from anybody.

AJ

So what am I supposed to do? A week later - still no responses, tech support is non-existent. This is unbelievably lame. Back when SketchUp belonged to Google it worked. Now I don’t know what to think about the whole operation. I think I am going to ask for a refund. Shame.

AJ

Sorry, I could help you were you on Mac. PC doesn’t have quite the diagnostics I have on Mac (namely DTrace from Sun / Oracle). Maybe someone’s got a similar tracing tool around, and I’ll ping support folks.

Please message your email address so that I can look up the case.

Barry,

Appreciate your suggestion, but what I don’t understand is why SketchUp itself has no error-logging facility built-in…

AJ

Um… because we’re perfect? :slight_smile: On Mac, you can certainly use Console.app and search for logs and find / solve issues. We catch crashes and analyze them. We do a lot of things to help. As an ex-Apple guy, I’m just not equipped to help you troubleshoot on PC. I’ll leave that to others.

First of all, thanks to Yogesh for offering to help over the phone. It turned out to be unnecessary, as I discovered the reason for my export functionality misbehaving. The culprit was a third-party, purportedly anti-malware app called ByteFence that somehow made it onto my system, most probably via a quietly-bundled install.

What tipped me off was the Adobe Creative Cloud updates failing also. In the Adobe CC forums somebody noted ByteFence as the reason, and - unsurprisingly - as soon as I removed ByteFence from my system, not only CC updates, but SketchUp exports started working as expected.

Thanks to all who tried to help, and apologies to the SketchUp Team for any offence I may have caused due to my frustration. You guys rock - even though it took 11 days for any serious attempt at resolving my issue. :slight_smile:

AJ

Seriously, that’s what you got from this!

You were lucky. These kind of “security applications” are known to do much worse things.

Anssi