Export as .PNG becomes ugly


#1

My students are using SketchUp for schools for a while.
In the beginning, when they export, some styles were to soft.
It lookes like SketchUp solved this problem, because they pictures became more clear for half a year.
But now we have a new problem:
A lot of pictures turn out very ugly. They get wrong colours in windows and in water, and not even only there…
You can see it very well in this swimmingpool. It should be filled with water, but there is some strange pink layer over it.
Sometimes the windows with glass turn out to be pink or green.
I solved this problem by letting the children make a print screen of their object, instead of exporting, but it takes a lot of efford to cut out the real picture.
What is happening and can you please solve this problem, SketchUp?

I think it has something to do with the graphics card which can’t handle exporting. But this is the type of carts schools use when they buy new chromebooks. In the past this wasn’t a problem and this carts could handle exporting.
So please SketchUp, change this so my students can make beautifull pictures of their work!


#2

Any chance you can share the SKP file from which your screenshot was made? Let us look at it to see if we get the same results. It might be something related to the way the model is made although I suspect it’s a graphics card thing.


#3

I tried to export the file on my own computer, wich is a lot better than the computers in school. But I still got the same problem. I’m very curious what happeness when you do it too, DaveR!

mer_zwembad_01.skp (1.1 MB)


#4

This is what it should look like!
(I made a screenshot.)


#5

This is what I get when I export the image via SketchUp Pro.

And when exported from SketchUp Free.

It would appear that WebGL has some issues with the texture from the watermark. When I export without the watermark image it looks like this.

For the time being, anyway, I would suggest that the students don’t use styles with watermark image overlays.


#6

Thank you DaveR, for finding this out.

I think SketchUp has a task, to make this (and some other) watermark/style work!


#7

I did a test where I put an image behind the model instead of a watermark, and still the colors were not right. That makes it seem like a transparency issue and not a watermark one.


#8

You could be right, Colin. The bottom of the pool is painted with the transparent material, too. Interestingly, the transparency of the material on the pool isn’t a problem without the watermark image.


#9

In your 3rd image the small hole has pink at the bottom. Out of curiosity I tried it in Free, whenever I have a transparent bottom all the bottom on export comes out a green colour. The only way I could get it to show properly were to have a non-transparent material on the bottom of the pool. I wouldn’t have thought the bottom would be transparent anyway.

Pro works fine with the original as yours though.


#10

I didn’t fix that face before making the screen shot.


#11

That explains that one then!


#12

Great how you think about this and help me!

I have another example, unfortunately it’s a common problem.
And this isn’t about transparancy…
What do you think of this?

This is the file:
kast_ros.skp (592.5 KB)

This is the exported picture:

This is a print screen:


#13

Actually, it is about transparency. It’s the transparency of the gradient and grain overlays in the watermark. As I said before, I think it’s best to avoid the those styles with the watermarks for image exports. Or teach the students how to make screen shots. Or use a desktop client version of SketchUp to make the image exports.

I don’t know if this is something that can be fixed by the SketchUp team or if it’s a limitation of WebGL but until it is resolved, if it can be resolved, transparent watermarks aren’t going to make such nice looking PNG images so other approaches will be needed.


#14

I understand what you mean.

I think SketchUp is still trying to make the watermarks work right in SfS/Sfree


This is the watermark a year before. It was to soft…
SketchUp did solve this problem.
But now other styles have problem’s, they didn’t had before…

SketchUp should be able to solve problems, that weren;t there before. I have seen this styles work well. I hope they’ll solve this problems soon…
And meanwhile I use the solutions you pointed, Dave.


#15

Does the Free version have the same transparency quality settings available as the desktop versions? Usually setting the transparency to Better fixes many issues like this.


#16

There are no options to edit styles in SketchUp Free like there are in the desktop client versions.


#17

Thanks for the report and thanks everyone for the great analysis. I logged this issue and we’ll look into it.

Bugra


#18

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.