Export as pdf - Some viewpoints 'Style' changing

Hi,

I am having some issues which are presenting as certain viewports changing style.

I have exported the same document several times without changing anything - and the same viewport would export in ‘hidden line’ style instead of the ‘architectural’ style that I haave specified on the layout drawing.

When I exported a final time to show screenshots - the offending viewport appears correctly.

However this time, a different viewport on a different page has appeared with a background that does not appear in the layout.

A seemingly related issue is that any bold type text is not carried through to the export. I have encountered this before and overcome by printing as pdf and changing font settings - but if there is an in-Layout way around this I would be great).

Has anybody here experienced this? Does anyone have any advice?

Thank you

Can you share the LayOut file so we can see what you are working with?

As for the text, what font are you using?

1 Like

Hi,

The font is called Didact Gothic - there is no bold in the typeface family.

Sorry the forum won’t allow me to upload the file as it is larger than 16MB

Upload it to DropBox and share the link.

1 Like

Thank you

Here’s the PDF I get when I export that page from LayOut. No background displayed in the plan view of the deck and the style shows set to Hidden Line so it’s remaining as black lines and white.
ECO06XX3-001 - 3000 x 40 x 40mm Clarity-Legna Angle Trim.pdf (236.1 KB)

As for the bold font, I can tell which ones specifically you’re seeing as bold. Some of the text is not Didact Gothic. It’s Verdana and the larger font size is set to be bold.

I didn’t do anything to your file except look at how you have things set up. I’d make some suggestions about that but probably not for this thread.

1 Like

Thanks for the reply Dave. As an aside I would be interested in your input on how page is set up.

The text I was referring to was actually the product codes on p1.

Do you know why this is happening?

Obviously the elevations in your pdf export are showing in shaded Artchitectural style in a background - as opposed to the hidden line style in the layout.

As I said earlier - a viewport in the second page (upper right iso of steps) - exported as hidden line about 6 r 6 times before finally coming out as the non-boackground shaded syle that is on the layout page.

Is there any known reason why this would change from one export to the next without changing anything?

ECO06XX3-001 - 3000 x 40 x 40mm Clarity-Legna Angle Trim.pdf (6.9 MB)
I have just downloaded my Layout file from dropbox - and exported and as attached you can see once again the top right viewport on p3 has lost ists colour - and the plan view on p3 has exported with a background.

I literally downloaded the same file I sent to you, opened it and clicked file >export >pdf

Some of that text is actually set to be bold.

Sorry. I was looking at the plan and missed the other two. The background was turned on for those two viewports. I think there’s a corruption in the file for the end elevation viewport. I did go into the SketchUp file and change the style for that scene to Hidden Line with no background and relinked the file.
Screenshot - 1_28_2022 , 10_11_53 AM

As for the third page, I fixed that model, too, and set up the scene correctly. This is from the PDF.

Personally I would have set up separate scenes for the plan and elevation views in SketchUp instead of modifying the Camera position in LO. The way you’ve done it could create a lot more work for you down the road than you save by using the same scene. I strongly recommend that you don’t do anything in LayOut that results in the Camera section of the SketchUp Model panel showing a Reset button. I think it’s fine for one-off documents that you will never need to go back to but for something like this one, you’ll save yourself a lot of trouble if set up the views as scenes in SketchUp instead.

A few notes about your SketchUp files.

I fixed incorrect tag usage and purged unused stuff from the files.

Screenshot - 1_28_2022 , 9_38_00 AM
Not too much unused stuff compared to your other file.
Screenshot - 1_28_2022 , 9_38_20 AM

Screenshot - 1_28_2022 , 10_20_12 AM
Screenshot - 1_28_2022 , 10_20_49 AM


Screenshot - 1_28_2022 , 10_37_53 AM
Screenshot - 1_28_2022 , 10_38_48 AM

Still more to look at.

HI Dave,

Thanks again for your reply.

I think I have found a solution - in resetting, the selected my preferred Style - I seem to have consistent results in .

Regarding the views - I have now since converted to using scenes only to select view (changing view within LO was proving far to slow), but this is an earlier file I made when I was just starting with LO.

Is it fair to say this is a known issue - to have issues when trying change viewport styles, views within LO?

Regarding the text that is set to bold - that is what I was trying to point out. The bold text that you have kindly screenshotted does not carry through upon export to pdf. -
I would be grateful if you had a workaround for this? (I have had some success playing with settings when using ‘print to pdf’ - but this is inconsistent- and obviously takes a lot longer than simple export to pdf so is not ideal).

Once again, thanks a lot for your help!!