Error when running sketchup 2024

How to restore settings to classic engine in Sketchup 2024? After changing to a new engine, sketchup 2024 starts for a few seconds or not at all - I have no chance to change it in the settings.

Navigate to:

%LocalAppData%/SketchUp/SketchUp 2024/SketchUp/

… open the PrivatePreferences.json file in a good code editor (that will not change the encoding).

The setting is at:

"This Computer Only" > "Preferences" > "UseNewRenderer"

Valid values are: true and false


There is also a option to choose the GPU:

"This Computer Only" > "Preferences" > "SelectedGPU"

Valid values are:

  • "SystemDefaultGPU"

  • and the name of your particular discrete GPU



Two Free Code editors:

1 Like

Thank you very much, it works:)

1 Like

For me it doesn’t change anything sketchup always crashes but not systemmatic, I suspect the validation mechanism of the crashed plugins.

What is more annoying is sketchup no longer displays an error box, how can we investigate if we are taken away from what we can do with it!!!