Error message

When i open Sketchup 2017 i get this error:
Error: #<TypeError: no implicit conversion of nil into String>
c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_advancedcameratools/advancedcameratools_main.rbe:3643:in large_icon=' c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_advancedcameratools/advancedcameratools_main.rbe:3643:inadd_camera_menus’
c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_advancedcameratools/advancedcameratools_main.rbe:3870:in <main>' c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_advancedcameratools/actloader.rbe:9:ineval’
c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_advancedcameratools/actloader.rbe:9:in require' c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_advancedcameratools/actloader.rbe:9:in
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in eval' C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:inrequire’
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in load' C:/Users/Eric Malihan/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools.rb:44:inregister_extension’
C:/Users/Eric Malihan/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools.rb:44:in <top (required)>' Error: #<TypeError: no implicit conversion of nil into String> c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:121:inlarge_icon=’
c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:121:in initialize' c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:1033:innew’
c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:1033:in <main>' c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_dynamiccomponents/ruby/dcloader.rbe:16:ineval’
c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_dynamiccomponents/ruby/dcloader.rbe:16:in require' c:/users/eric malihan/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_dynamiccomponents/ruby/dcloader.rbe:16:in
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in eval' C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:inrequire’
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in load' C:/Users/Eric Malihan/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents.rb:46:inregister_extension’
C:/Users/Eric Malihan/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents.rb:46:in `<top (required)>’

What is this?

check Extension Manager to see if Advanced Camera Tools and Dynamic Component Tools are up to date…

if not, update them, then disable them if you do not use either…

john

On Windows this is sometimes related to an incorrect installation of SketchUp.
You can try this to repair it…
Whilst logged into Windows as your normal user-account, ensure SketchUp is closed.
Find the v2017 Sketchup installer’s exe file - probably in your Downloads folder [or download a new one for v2017].
Select the exe file’s icon, right-click > context-menu > “Run as administrator”
When prompted choose “Repair”.
When it completes restart SketchUp and see if that helped…

Installing any complex app in any other way can cause weird permission issues - so I suspect the RBE files are no getting properly copied over into your users Plugins folder [SketchUp copies them over from its ShippedExtensions folder when it runs].
You can try erasing the Plugins folder’s su_ RB files and su_ subfolders and ensure a fresh set is copied over…
Double-clicking on an installer’s exe file ro “Run” it is NOT the same as “Running as administrator”, even if your normal user-account has some admin-powers !

Advanced Camera Tools i can’t use it because i have no 2017 Pro.

Repair is finish but when starting Sketchup 2017 i get the same error to see.

Did you try the second part of the possible ‘fix’ ?

… You can try erasing the Plugins folder’s su_ RB files and su_ subfolders and ensure a fresh set is copied over [when SketchUp restarts]…

Failing that… get fresh copies of the ShippedExtensions from the EWH and install them.
Then [before closing SketchUp] copy all of those su_RB and su_ subfolders back into the ShippedExtensions so that a ‘good’ set is always available…