Erasing construction lines

I use construction lines a lot so I am forever creating and deleting them. If I have to delete a number at once, I try doing what I would with any other geometry by starting with a bounding rectangle. However, almost invariably, that fails to select all within the box. This peculiar anomaly only seems to affect construction lines. I wonder whether this is a Mac only thing. It has been happening for years.

Anyone else find this?

Doesn’t a selection box only select construction lines by their insertion points. They are hard to see and may be spread all over modeling space depending on where and how you created them. Just my guess, no program available at the momemt.

p.s. If you group a single construction line you’ll see that it has that specific insertion point, the local group’s origin.

I’m not understanding why you don’t use Edit/Delete Guides ?

I do - when I want to get rid of all of them. In fact I have a shortcut to do that. But I often just want to get rid of a few at a time which means selecting them.

But this slightly begs the question. I have lived with this a long time and am just curious to know why it doesn’t work the way one might expect. Or indeed with consistency.

We would have to see what you are doing to be able to give a clear answer, but as with geometry the construction lines need to be fully contained within a left to right selection box to be selected. So infinite ones will never select, only fully contained endpoints with tails.

It’s really hard to reproduce on demand. I tried recording it but of course it then worked perfectly. Just like taking your car in. If I come across an instance where it fails repeatedly, I will see if I can record it. But basically I am using a selection rectangle starting bottom right and ending top left that encompasses the lines. As I said, if it were anything else, like actual lines, there would be no problem.

I am not even sure I know what this means. The construction line is often an offset using the Tape Measure tool so there is no point - unless you mean where you might click to start it. But you don’t have to envelop the start of an ordinary line to select it.

I should say that when this happens, I revert to using the pointer tool and select the lines individually. Now that does always work.

I’ve found zooming in and then a small right to left selection over a small section of the guide lines highlights only them and then I hit erase.

Try this:
Drag a construction line from the red axis from say aproximatelyy 1.5m from the origin to an arbitrary location.
Do the same again from say 1.9m to nearby the first construction line.
Both these guides are parallel to each other and to the red axis. But their insertion points differ in the red direction by 0.4m
Look closely at these locations (1.5m and 1.9m) on each respectieve guide. The dashed lines show some irragularity, the insertion points

Do a window selection in various ways:

  • including both selection points
  • excluding one insertion point but part of both guides
  • excluding both insertion points but part of both guides

Does this show you any difference in selection results?

1 Like

I can now see what you mean by insertion points. There are indeed slightly longer dashes opposite the points I selected on the red axis. After nearly 20 years of using SU, it’s the first I have heard and found out about this!

I started by selecting the lines outside the insertion points. That succeeded in selecting one of the lines only. Then I tried it including one selection point, then both, then neither again. On each of these occasions, I successfully selected both lines.

So my conclusion seems to be:

  1. If you can see the insertion points of all your lines and can encomapss them, you may successfully select all, but it is very unlikely you would identify them all and frankly, life is too short!

  2. Selecting construction lines does not work the same as for actual geometry. It seems to be haphazard.

  3. It is probably easiest to use my shortcut to delete all construction lines and start afresh when I need others.

  4. Not having read about this before, I guess it is not something that bothers others much, so probably best to just use a workaround.